CVE-2024-45478 Apache Ranger: Stored XSS in Edit Service page - Add logic to validate user input

Medium 4.8 Published Updated

Attackers can inject malicious scripts into the Apache Ranger UI, potentially leading to session hijacking or unauthorized actions.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-45478?

CVE-2024-45478 is a medium-severity cross-site scripting vulnerability in Apache Ranger, published on 21 Jan 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Stored XSS vulnerability in Edit Service Page of Apache Ranger UI in Apache Ranger Version 2.4.0. Users are recommended to upgrade to version Apache Ranger 2.5.0, which fixes this issue.

Weakness: CWE-79

Which versions are affected by CVE-2024-45478?

2 open source packages ship an affected version, including org.apache.ranger:ranger. It affects 1 product.

PackageAffectedFixed in
org.apache.ranger:ranger MavenAll versions2.5.0
org.apache.ranger:ranger MavenAll versions2.5.0

Products include Apache Ranger.

How do I fix CVE-2024-45478?

Upgrade org.apache.ranger:ranger to 2.5.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-45478 being exploited?

There is no known exploitation of CVE-2024-45478 in the wild and no public exploit code.

Sources

Also known as GHSA-vrx2-mgr9-v67h.

Is CVE-2024-45478 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free