# CVE-2024-45478: Apache Ranger: Stored XSS in Edit Service page - Add logic to validate user input

> Attackers can inject malicious scripts into the Apache Ranger UI, potentially leading to session hijacking or unauthorized actions.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Jan 2025
- **Updated:** 10 Jun 2025
- **Also known as:** GHSA-vrx2-mgr9-v67h

## What is CVE-2024-45478?

CVE-2024-45478 is a medium-severity cross-site scripting vulnerability in Apache Ranger, published on 21 Jan 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Stored XSS vulnerability in Edit Service Page of Apache Ranger UI in Apache Ranger Version 2.4.0.
Users are recommended to upgrade to version Apache Ranger 2.5.0, which fixes this issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-45478?

2 open source packages ship an affected version, including org.apache.ranger:ranger. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.ranger:ranger` | Maven | All versions | 2.5.0 |
| `org.apache.ranger:ranger` | Maven | All versions | 2.5.0 |

Products: Apache Ranger.

## How do I fix CVE-2024-45478?

Upgrade org.apache.ranger:ranger to 2.5.0 or later.

## Is CVE-2024-45478 being exploited?

There is no known exploitation of CVE-2024-45478 in the wild and no public exploit code.

## Other vulnerabilities in Apache Ranger

- [CVE-2026-28672](https://insights.sbomify.com/CVE-2026-28672/): Apache Ranger: OS Command Injection via Username in UnixUserGroupBuilder (critical 9.8)
- [CVE-2026-32227](https://insights.sbomify.com/CVE-2026-32227/): Apache Ranger: SQL Injection vulnerability in lookup functionality (critical 9.8)
- [CVE-2026-40920](https://insights.sbomify.com/CVE-2026-40920/): Apache Ranger: Privilege Escalation via URL Parameter (critical 9.8)
- [CVE-2026-42537](https://insights.sbomify.com/CVE-2026-42537/): Apache Ranger: Remote Code Execution via JDBC URL Injection (critical 9.8)
- [CVE-2026-44416](https://insights.sbomify.com/CVE-2026-44416/): Apache Ranger: Remote Code Execution via Arbitrary Class Instantiation (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45478 and fix it if it is affected.

What it is: CVE-2024-45478 is a medium-severity cross-site scripting vulnerability in Apache Ranger, published on 21 Jan 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-45478 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.ranger:ranger (Maven): affected all versions; fixed in 2.5.0
- org.apache.ranger:ranger (Maven): affected all versions; fixed in 2.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45478/ (Markdown: https://insights.sbomify.com/CVE-2024-45478/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45478
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45478
- OSV: https://osv.dev/vulnerability/CVE-2024-45478

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45478/
Summaries are generated and may contain mistakes; the official description above is the record.
