# CVE-2024-45488: Auth bypass in n/a

> Attackers can gain unauthorized access to One Identity Safeguard for Privileged Passwords virtual appliances via cookie manipulation, leading to potential account takeover.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 30 Aug 2024
- **Updated:** 13 Mar 2025
- **Also known as:** GHSA-c2jm-97rm-g3c3

## What is CVE-2024-45488?

CVE-2024-45488 is a critical authentication bypass vulnerability in n/a, published on 30 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

One Identity Safeguard for Privileged Passwords before 7.5.2 allows unauthorized access because of an issue related to cookies. This only affects virtual appliance installations (VMware or HyperV). The fixed versions are 7.0.5.1 LTS, 7.4.2, and 7.5.2.

## Which versions are affected by CVE-2024-45488?


## How do I fix CVE-2024-45488?

No fix has been published for CVE-2024-45488 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-45488 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45488 exists.

Public exploit code:

- SafeGuard for Privileged Passwords < 7.5.2 - Authentication Bypass (nuclei): http/cves/2024/CVE-2024-45488.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45488 and fix it if it is affected.

What it is: CVE-2024-45488 is a critical authentication bypass vulnerability in n/a, published on 30 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45488 exists.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45488/ (Markdown: https://insights.sbomify.com/CVE-2024-45488/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45488
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45488
- OSV: https://osv.dev/vulnerability/CVE-2024-45488

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45488/
Summaries are generated and may contain mistakes; the official description above is the record.
