# CVE-2024-45493: Auth bypass in n/a

> Attackers can bypass local-only restrictions to authenticate as internal users over the network if they possess valid credentials.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Dec 2024
- **Updated:** 6 Jan 2025
- **Also known as:** GHSA-5xh8-mfhp-x7wc

## What is CVE-2024-45493?

CVE-2024-45493 is a critical authentication bypass vulnerability in n/a, published on 10 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in MSA FieldServer Gateway 5.0.0 through 6.5.2 (Fixed in 7.0.0). The FieldServer Gateway has internal users, whose access is supposed to be restricted to login locally on the device. However, an attacker can bypass the check for this, which might allow them to authenticate with an internal user account from the network (if they know their password).

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-45493?


## How do I fix CVE-2024-45493?

No fix has been published for CVE-2024-45493 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-45493 being exploited?

There is no known exploitation of CVE-2024-45493 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45493 and fix it if it is affected.

What it is: CVE-2024-45493 is a critical authentication bypass vulnerability in n/a, published on 10 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-45493 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45493/ (Markdown: https://insights.sbomify.com/CVE-2024-45493/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45493
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45493
- OSV: https://osv.dev/vulnerability/CVE-2024-45493

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45493/
Summaries are generated and may contain mistakes; the official description above is the record.
