CVE-2024-45506 Denial of service in n/a
Remote attackers can cause a denial of service in HAProxy via HTTP/2 zero-copy forwarding loops, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-45506?
CVE-2024-45506 is a high-severity denial of service vulnerability in n/a, published on 4 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
HAProxy 2.9.x before 2.9.10, 3.0.x before 3.0.4, and 3.1.x through 3.1-dev6 allows a remote denial of service for HTTP/2 zero-copy forwarding (h2_send loop) under a certain set of conditions, as exploited in the wild in 2024.
Weakness: CWE-835
Which versions are affected by CVE-2024-45506?
1 open source package ship an affected version, including haproxy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
haproxy Bitnami | From 2.9.0 | 2.9.10, 3.0.4 |
Linux distribution packages (1)
haproxy openSUSE:Tumbleweed | All versions | 3.0.4+git0.7a59afa93-1.1 |
Products include Haproxy Haproxy.
How do I fix CVE-2024-45506?
Upgrade haproxy to a fixed version for your release line: 2.9.10 or 3.0.4.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-45506 being exploited?
There is no known exploitation of CVE-2024-45506 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as AZL-48668, BIT-haproxy-2024-45506, DEBIAN-CVE-2024-45506, GHSA-gmvf-rv8w-2hrh, OESA-2024-2130, openSUSE-SU-2024:14307-1.