{"answers":{"affected":"1 open source package ship an affected version, including haproxy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-45506 in the wild and no public exploit code.","fix":"Upgrade haproxy to a fixed version for your release line: 2.9.10 or 3.0.4.","what":"CVE-2024-45506 is a high-severity denial of service vulnerability in n/a, published on 4 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-45506 and fix it if it is affected.\n\nWhat it is: CVE-2024-45506 is a high-severity denial of service vulnerability in n/a, published on 4 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-45506 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- haproxy (Bitnami): affected from 2.9.0; fixed in 2.9.10, 3.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-45506/ (Markdown: https://insights.sbomify.com/CVE-2024-45506/index.md)","id":"CVE-2024-45506","markdown":"https://insights.sbomify.com/CVE-2024-45506/index.md","name":"CVE-2024-45506","record":{"aliases":["AZL-48668","BIT-haproxy-2024-45506","DEBIAN-CVE-2024-45506","GHSA-gmvf-rv8w-2hrh","OESA-2024-2130","openSUSE-SU-2024:14307-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"HAProxy load balancer","requires_auth":"none","summary":"Remote attackers can cause a denial of service in HAProxy via HTTP/2 zero-copy forwarding loops, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"haproxy","vendor":"haproxy"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"}],"description":"HAProxy 2.9.x before 2.9.10, 3.0.x before 3.0.4, and 3.1.x through 3.1-dev6 allows a remote denial of service for HTTP/2 zero-copy forwarding (h2_send loop) under a certain set of conditions, as exploited in the wild in 2024.","ecosystems":["Bitnami","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2024-45506","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":6,"next":{"headline":"Apache OFBiz: Prevent use of URLs in files when loading them from Java or Groovy, leading to a RCE","id":"CVE-2024-45507"},"packages":[{"ecosystem":"Bitnami","fixed":["2.9.10","3.0.4"],"introduced":["2.9.0","3.0.0"],"last_affected":[],"package":"haproxy","purl":"pkg:bitnami/haproxy","source":"BIT-haproxy-2024-45506"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.0.4+git0.7a59afa93-1.1"],"introduced":["0"],"last_affected":[],"package":"haproxy","purl":"pkg:rpm/opensuse/haproxy\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14307-1"}],"prev":{"headline":"Apache HertzBeat: Exists Native Deser RCE and file writing vulnerabilities","id":"CVE-2024-45505"},"products":["n/a"],"published":"2024-09-04","related":[{"cvss_score":9,"headline":"HAProxy - Integer Overflow in FCGI Demux Record Length Field","id":"CVE-2026-55203","kev_date_added":null,"published":"2026-06-18"},{"cvss_score":8.7,"headline":"HAProxy - NULL Pointer Dereference in hpack_dht_insert Function","id":"CVE-2026-55204","kev_date_added":null,"published":"2026-06-18"},{"cvss_score":8.2,"headline":"Information disclosure in n/a","id":"CVE-2023-45539","kev_date_added":null,"published":"2023-11-28"},{"cvss_score":7.5,"headline":"Information disclosure in HAProxy","id":"CVE-2023-0836","kev_date_added":null,"published":"2023-03-29"},{"cvss_score":7.5,"headline":"Other in n/a","id":"CVE-2019-18277","kev_date_added":null,"published":"2019-10-23"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2019-14241","kev_date_added":null,"published":"2019-07-23"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-14","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service in HAProxy via HTTP/2 zero-copy forwarding loops, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2024-45506/"}