# CVE-2024-45506: Denial of service in n/a

> Remote attackers can cause a denial of service in HAProxy via HTTP/2 zero-copy forwarding loops, requiring an upgrade to patched versions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2024
- **Updated:** 14 Mar 2025
- **Also known as:** AZL-48668, BIT-haproxy-2024-45506, DEBIAN-CVE-2024-45506, GHSA-gmvf-rv8w-2hrh, OESA-2024-2130, openSUSE-SU-2024:14307-1

## What is CVE-2024-45506?

CVE-2024-45506 is a high-severity denial of service vulnerability in n/a, published on 4 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HAProxy 2.9.x before 2.9.10, 3.0.x before 3.0.4, and 3.1.x through 3.1-dev6 allows a remote denial of service for HTTP/2 zero-copy forwarding (h2_send loop) under a certain set of conditions, as exploited in the wild in 2024.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2024-45506?

1 open source package ship an affected version, including haproxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `haproxy` | Bitnami | From 2.9.0 | 2.9.10, 3.0.4 |
| `haproxy` | openSUSE:Tumbleweed | All versions | 3.0.4+git0.7a59afa93-1.1 |

Products: Haproxy Haproxy.

## How do I fix CVE-2024-45506?

Upgrade haproxy to a fixed version for your release line: 2.9.10 or 3.0.4.

## Is CVE-2024-45506 being exploited?

There is no known exploitation of CVE-2024-45506 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-55203](https://insights.sbomify.com/CVE-2026-55203/): HAProxy - Integer Overflow in FCGI Demux Record Length Field (critical 9.0)
- [CVE-2026-55204](https://insights.sbomify.com/CVE-2026-55204/): HAProxy - NULL Pointer Dereference in hpack_dht_insert Function (high 8.7)
- [CVE-2023-45539](https://insights.sbomify.com/CVE-2023-45539/): Information disclosure in n/a (high 8.2)
- [CVE-2023-0836](https://insights.sbomify.com/CVE-2023-0836/): Information disclosure in HAProxy (high 7.5)
- [CVE-2019-18277](https://insights.sbomify.com/CVE-2019-18277/): Other in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45506 and fix it if it is affected.

What it is: CVE-2024-45506 is a high-severity denial of service vulnerability in n/a, published on 4 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-45506 in the wild and no public exploit code.

Affected packages and fixed versions:
- haproxy (Bitnami): affected from 2.9.0; fixed in 2.9.10, 3.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45506/ (Markdown: https://insights.sbomify.com/CVE-2024-45506/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45506
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45506
- OSV: https://osv.dev/vulnerability/CVE-2024-45506

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45506/
Summaries are generated and may contain mistakes; the official description above is the record.
