# CVE-2024-45591: XWiki Platform document history including authors of any page exposed to unauthorized actors

> Attackers can access page history and author details via the REST API, even on private wikis, exposing sensitive metadata.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Sep 2024
- **Updated:** 10 Sep 2024
- **Also known as:** GHSA-pvmm-55r5-g3mm

## What is CVE-2024-45591?

CVE-2024-45591 is a medium-severity vulnerability in Xwiki Xwiki, published on 10 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform. The REST API exposes the history of any page in XWiki of which the attacker knows the name. The exposed information includes for each modification of the page the time of the modification, the version number, the author of the modification (both username and displayed name) and the version comment. This information is exposed regardless of the rights setup, and even when the wiki is configured to be fully private. On a private wiki, this can be tested by accessing /xwiki/rest/wikis/xwiki/spaces/Main/pages/WebHome/history, if this shows the history of the main page then the installation is vulnerable. This has been patched in XWiki 15.10.9 and XWiki 16.3.0RC1.

Weakness: CWE-862 (Missing Authorization), CWE-359 (Exposure of Private Personal Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-45591?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-rest-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 1.8.0 | 15.10.9 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 1.8.0 | 15.10.9 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 16.0.0-rc-1 | 16.3.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 16.0.0-rc-1 | 16.3.0-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2024-45591?

Upgrade org.xwiki.platform:xwiki-platform-rest-server to a fixed version for your release line: 15.10.9 or 16.3.0-rc-1.

## Is CVE-2024-45591 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45591 exists.

Public exploit code:

- XWiki Platform - Unauthorized Document History Access (nuclei): http/cves/2024/CVE-2024-45591.yaml

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45591 and fix it if it is affected.

What it is: CVE-2024-45591 is a medium-severity vulnerability in Xwiki Xwiki, published on 10 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45591 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 1.8.0; fixed in 15.10.9
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 1.8.0; fixed in 15.10.9
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 16.0.0-rc-1; fixed in 16.3.0-rc-1
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 16.0.0-rc-1; fixed in 16.3.0-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45591/ (Markdown: https://insights.sbomify.com/CVE-2024-45591/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45591
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45591
- OSV: https://osv.dev/vulnerability/CVE-2024-45591

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45591/
Summaries are generated and may contain mistakes; the official description above is the record.
