CVE-2024-45592 auditor-bundle vulnerable to Cross-site Scripting because name of entity does not get escaped
Attackers can inject malicious scripts via unescaped entity names in the Symfony auditor bundle, potentially executing code in user sessions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-45592?
CVE-2024-45592 is a high-severity cross-site scripting vulnerability in DamienHarper auditor-bundle, published on 10 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
auditor-bundle, formerly known as DoctrineAuditBundle, integrates auditor library into any Symfony 3.4+ application. Prior to version 5.2.6, there is an unescaped entity property enabling Javascript injection. This is possible because `%source_label%` in twig macro is not escaped. Therefore script tags can be inserted and are executed. The vulnerability is fixed in versions 6.0.0 and 5.2.6.
Weakness: CWE-79
Which versions are affected by CVE-2024-45592?
2 open source packages ship an affected version, including damienharper/auditor-bundle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
damienharper/auditor-bundle Packagist | All versions | 5.2.6 |
damienharper/auditor-bundle Packagist | All versions | 5.2.6 |
Products include Damienharper Auditor-Bundle.
How do I fix CVE-2024-45592?
Upgrade damienharper/auditor-bundle to 5.2.6 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-45592 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45592 exists.
Sources
Also known as GHSA-78vg-7v27-hj67.