{"answers":{"affected":"2 open source packages ship an affected version, including damienharper/auditor-bundle. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45592 exists.","fix":"Upgrade damienharper/auditor-bundle to 5.2.6 or later.","what":"CVE-2024-45592 is a high-severity cross-site scripting vulnerability in DamienHarper auditor-bundle, published on 10 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-45592 and fix it if it is affected.\n\nWhat it is: CVE-2024-45592 is a high-severity cross-site scripting vulnerability in DamienHarper auditor-bundle, published on 10 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45592 exists.\n\nAffected packages and fixed versions:\n- damienharper/auditor-bundle (Packagist): affected all versions; fixed in 5.2.6\n- damienharper/auditor-bundle (Packagist): affected all versions; fixed in 5.2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-45592/ (Markdown: https://insights.sbomify.com/CVE-2024-45592/index.md)","id":"CVE-2024-45592","markdown":"https://insights.sbomify.com/CVE-2024-45592/index.md","name":"CVE-2024-45592","record":{"aliases":["GHSA-78vg-7v27-hj67"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Symfony auditor bundle","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts via unescaped entity names in the Symfony auditor bundle, potentially executing code in user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"auditor-bundle","vendor":"damienharper"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"auditor-bundle, formerly known as DoctrineAuditBundle, integrates auditor library into any Symfony 3.4+ application. Prior to version 5.2.6, there is an unescaped entity property enabling Javascript injection. This is possible because `%source_label%` in twig macro is not escaped. Therefore script tags can be inserted and are executed. The vulnerability is fixed in versions 6.0.0 and 5.2.6.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"auditor-bundle vulnerable to Cross-site Scripting because name of entity does not get escaped","id":"CVE-2024-45592","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Nix affected by unsafe NAR unpacking","id":"CVE-2024-45593"},"packages":[{"ecosystem":"Packagist","fixed":["5.2.6"],"introduced":["0"],"last_affected":[],"package":"damienharper/auditor-bundle","purl":null,"source":"GHSA-78vg-7v27-hj67"},{"ecosystem":"Packagist","fixed":["5.2.6"],"introduced":["0"],"last_affected":[],"package":"damienharper/auditor-bundle","purl":"pkg:composer/damienharper/auditor-bundle","source":"GHSA-78vg-7v27-hj67"}],"prev":{"headline":"XWiki Platform document history including authors of any page exposed to unauthorized actors","id":"CVE-2024-45591"},"products":["auditor-bundle"],"published":"2024-09-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-20","vendors":["DamienHarper"]},"summary":"Attackers can inject malicious scripts via unescaped entity names in the Symfony auditor bundle, potentially executing code in user sessions.","url":"https://insights.sbomify.com/CVE-2024-45592/"}