# CVE-2024-45592: auditor-bundle vulnerable to Cross-site Scripting because name of entity does not get escaped

> Attackers can inject malicious scripts via unescaped entity names in the Symfony auditor bundle, potentially executing code in user sessions.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Sep 2024
- **Updated:** 20 Sep 2024
- **Also known as:** GHSA-78vg-7v27-hj67

## What is CVE-2024-45592?

CVE-2024-45592 is a high-severity cross-site scripting vulnerability in DamienHarper auditor-bundle, published on 10 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

auditor-bundle, formerly known as DoctrineAuditBundle, integrates auditor library into any Symfony 3.4+ application. Prior to version 5.2.6, there is an unescaped entity property enabling Javascript injection. This is possible because `%source_label%` in twig macro is not escaped. Therefore script tags can be inserted and are executed. The vulnerability is fixed in versions 6.0.0 and 5.2.6.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-45592?

2 open source packages ship an affected version, including damienharper/auditor-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `damienharper/auditor-bundle` | Packagist | All versions | 5.2.6 |
| `damienharper/auditor-bundle` | Packagist | All versions | 5.2.6 |

Products: Damienharper Auditor-Bundle.

## How do I fix CVE-2024-45592?

Upgrade damienharper/auditor-bundle to 5.2.6 or later.

## Is CVE-2024-45592 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45592 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45592 and fix it if it is affected.

What it is: CVE-2024-45592 is a high-severity cross-site scripting vulnerability in DamienHarper auditor-bundle, published on 10 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45592 exists.

Affected packages and fixed versions:
- damienharper/auditor-bundle (Packagist): affected all versions; fixed in 5.2.6
- damienharper/auditor-bundle (Packagist): affected all versions; fixed in 5.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45592/ (Markdown: https://insights.sbomify.com/CVE-2024-45592/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45592
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45592
- OSV: https://osv.dev/vulnerability/CVE-2024-45592

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45592/
Summaries are generated and may contain mistakes; the official description above is the record.
