CVE-2024-45594 Decidim allows cross-site scripting (XSS) in the online or hybrid meeting embeds

High 7.7 Published Updated

Attackers can execute arbitrary scripts in victim browsers via malformed URLs in Decidim meeting embeds, potentially leading to session hijacking or data theft.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-45594?

CVE-2024-45594 is a high-severity cross-site scripting vulnerability in decidim, published on 13 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Decidim is a participatory democracy framework. The meeting embeds feature used in the online or hybrid meetings is subject to potential XSS attack through a malformed URL. This vulnerability is fixed in 0.28.3 and 0.29.0.

Weakness: CWE-79

Which versions are affected by CVE-2024-45594?

2 open source packages ship an affected version, including decidim-meetings. It affects 1 product.

PackageAffectedFixed in
decidim-meetings RubyGemsFrom 0.28.00.28.3
decidim-meetings RubyGemsFrom 0.28.00.28.3

Products include Decidim Decidim.

How do I fix CVE-2024-45594?

Upgrade decidim-meetings to 0.28.3 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-45594 being exploited?

There is no known exploitation of CVE-2024-45594 in the wild and no public exploit code.

Sources

Also known as GHSA-j4h6-gcj7-7v9v.

Is CVE-2024-45594 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free