{"answers":{"affected":"2 open source packages ship an affected version, including decidim-meetings. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-45594 in the wild and no public exploit code.","fix":"Upgrade decidim-meetings to 0.28.3 or later.","what":"CVE-2024-45594 is a high-severity cross-site scripting vulnerability in decidim, published on 13 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-45594 and fix it if it is affected.\n\nWhat it is: CVE-2024-45594 is a high-severity cross-site scripting vulnerability in decidim, published on 13 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-45594 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- decidim-meetings (RubyGems): affected from 0.28.0; fixed in 0.28.3\n- decidim-meetings (RubyGems): affected from 0.28.0; fixed in 0.28.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-45594/ (Markdown: https://insights.sbomify.com/CVE-2024-45594/index.md)","id":"CVE-2024-45594","markdown":"https://insights.sbomify.com/CVE-2024-45594/index.md","name":"CVE-2024-45594","record":{"aliases":["GHSA-j4h6-gcj7-7v9v"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Decidim participatory democracy framework","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary scripts in victim browsers via malformed URLs in Decidim meeting embeds, potentially leading to session hijacking or data theft.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"decidim","vendor":"decidim"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Decidim is a participatory democracy framework. The meeting embeds feature used in the online or hybrid meetings is subject to potential XSS attack through a malformed URL. This vulnerability is fixed in 0.28.3 and 0.29.0.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Decidim allows cross-site scripting (XSS) in the online or hybrid meeting embeds","id":"CVE-2024-45594","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"D-Tale allows Remote Code Execution through the Query input on Chart Builder","id":"CVE-2024-45595"},"packages":[{"ecosystem":"RubyGems","fixed":["0.28.3"],"introduced":["0.28.0"],"last_affected":[],"package":"decidim-meetings","purl":null,"source":"GHSA-j4h6-gcj7-7v9v"},{"ecosystem":"RubyGems","fixed":["0.28.3"],"introduced":["0.28.0"],"last_affected":[],"package":"decidim-meetings","purl":"pkg:gem/decidim-meetings","source":"GHSA-j4h6-gcj7-7v9v"}],"prev":{"headline":"Nix affected by unsafe NAR unpacking","id":"CVE-2024-45593"},"products":["decidim"],"published":"2024-11-13","related":[{"cvss_score":9.3,"headline":"Decidim has a Cross-site scripting (XSS) vulnerability via user name field","id":"CVE-2026-23891","kev_date_added":null,"published":"2026-04-13"},{"cvss_score":9.1,"headline":"Decidim has broken access control in templates","id":"CVE-2023-36465","kev_date_added":null,"published":"2023-10-06"},{"cvss_score":8.2,"headline":"Decidim's private data exports can lead to data leaks","id":"CVE-2025-65017","kev_date_added":null,"published":"2026-02-03"},{"cvss_score":8.1,"headline":"Decidim Cross-site Scripting vulnerability in the external link redirections","id":"CVE-2023-32693","kev_date_added":null,"published":"2023-07-11"},{"cvss_score":8.1,"headline":"Decidim Cross-site Scripting vulnerability in the processes filter","id":"CVE-2023-34089","kev_date_added":null,"published":"2023-07-11"},{"cvss_score":7.5,"headline":"Decidim amendments can be accepted or rejected by anyone","id":"CVE-2026-40869","kev_date_added":null,"published":"2026-04-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-11-13","vendors":["decidim"]},"summary":"Attackers can execute arbitrary scripts in victim browsers via malformed URLs in Decidim meeting embeds, potentially leading to session hijacking or data theft.","url":"https://insights.sbomify.com/CVE-2024-45594/"}