{"answers":{"affected":"3 open source packages ship an affected version, including mesop.","exploited":"There is no known exploitation of CVE-2024-45601 in the wild and no public exploit code.","fix":"Upgrade mesop to 0.12.4 or later.","what":"CVE-2024-45601 is a high-severity path traversal vulnerability in google mesop, published on 18 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-45601 and fix it if it is affected.\n\nWhat it is: CVE-2024-45601 is a high-severity path traversal vulnerability in google mesop, published on 18 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-45601 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mesop (PyPI): affected from 0.9.0; fixed in 0.12.4\n- mesop (PyPI): affected from 0.9.0; fixed in 0.12.4\n- mesop (PyPI): affected from 0.9.0; fixed in 0.12.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-45601/ (Markdown: https://insights.sbomify.com/CVE-2024-45601/index.md)","id":"CVE-2024-45601","markdown":"https://insights.sbomify.com/CVE-2024-45601/index.md","name":"CVE-2024-45601","record":{"aliases":["GHSA-pmv9-3xqp-8w42","PYSEC-2026-1625"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python UI framework","requires_auth":"none","summary":"An attacker can read arbitrary files on the server via insufficient input validation in the static file serving endpoint of the Mesop framework.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Mesop is a Python-based UI framework designed for rapid web apps development. A vulnerability has been discovered and fixed in Mesop that could potentially allow unauthorized access to files on the server hosting the Mesop application. The vulnerability was related to insufficient input validation in a specific endpoint. This could have allowed an attacker to access files not intended to be served. Users are strongly advised to update to the latest version of Mesop immediately. The latest version includes a fix for this vulnerability. At time of publication 0.12.4 is the most recently available version of Mesop.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Local file Inclusion via static file serving functionality in Mesop","id":"CVE-2024-45601","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Directory traversal in the file selector widget in contao/core-bundle","id":"CVE-2024-45604"},"packages":[{"ecosystem":"PyPI","fixed":["0.12.4"],"introduced":["0.9.0"],"last_affected":[],"package":"mesop","purl":null,"source":"GHSA-pmv9-3xqp-8w42"},{"ecosystem":"PyPI","fixed":["0.12.4"],"introduced":["0.9.0"],"last_affected":[],"package":"mesop","purl":"pkg:pypi/mesop","source":"GHSA-pmv9-3xqp-8w42"},{"ecosystem":"PyPI","fixed":["0.12.4"],"introduced":["0.9.0"],"last_affected":[],"package":"mesop","purl":"pkg:pypi/mesop","source":"PYSEC-2026-1625"}],"prev":{"headline":"Fields GLPI plugin has an Authenticated SQL Injection","id":"CVE-2024-45600"},"products":["mesop"],"published":"2024-09-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-18","vendors":["google"]},"summary":"An attacker can read arbitrary files on the server via insufficient input validation in the static file serving endpoint of the Mesop framework.","url":"https://insights.sbomify.com/CVE-2024-45601/"}