{"answers":{"affected":"3 open source packages ship an affected version, including sentry. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-45605 in the wild and no public exploit code.","fix":"Upgrade sentry to 24.9.0 or later.","what":"CVE-2024-45605 is a medium-severity missing authorization vulnerability in getsentry sentry, published on 17 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-45605 and fix it if it is affected.\n\nWhat it is: CVE-2024-45605 is a medium-severity missing authorization vulnerability in getsentry sentry, published on 17 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-45605 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sentry (PyPI): affected from 23.9.0; fixed in 24.9.0\n- sentry (PyPI): affected from 23.9.0; fixed in 24.9.0\n- sentry (PyPI): affected from 23.9.0; fixed in 24.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-45605/ (Markdown: https://insights.sbomify.com/CVE-2024-45605/index.md)","id":"CVE-2024-45605","markdown":"https://insights.sbomify.com/CVE-2024-45605/index.md","name":"CVE-2024-45605","record":{"aliases":["GHSA-54m3-95j9-v89j","PYSEC-2026-1910"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Sentry error tracking","requires_auth":"low_privilege","summary":"Authenticated users can delete alert notifications for other users by exploiting missing authorization checks in Sentry.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sentry","vendor":"sentry"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"}],"description":"Sentry is a developer-first error tracking and performance monitoring platform. An authenticated user delete the user issue alert notifications for arbitrary users given a know alert ID. A patch was issued to ensure authorization checks are properly scoped on requests to delete user alert notifications. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 24.9.0 or higher. There are no known workarounds for this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper authorization on deletion of user issue alert notifications in sentry","id":"CVE-2024-45605","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"Improper authorization on muting of alert rules in sentry","id":"CVE-2024-45606"},"packages":[{"ecosystem":"PyPI","fixed":["24.9.0"],"introduced":["23.9.0"],"last_affected":[],"package":"sentry","purl":null,"source":"GHSA-54m3-95j9-v89j"},{"ecosystem":"PyPI","fixed":["24.9.0"],"introduced":["23.9.0"],"last_affected":[],"package":"sentry","purl":"pkg:pypi/sentry","source":"GHSA-54m3-95j9-v89j"},{"ecosystem":"PyPI","fixed":["24.9.0"],"introduced":["23.9.0"],"last_affected":[],"package":"sentry","purl":"pkg:pypi/sentry","source":"PYSEC-2026-1910"}],"prev":{"headline":"Directory traversal in the file selector widget in contao/core-bundle","id":"CVE-2024-45604"},"products":["sentry"],"published":"2024-09-17","related":[{"cvss_score":9.1,"headline":"Sentry: Improper authentication on SAML SSO process allows user identity linking","id":"CVE-2026-42354","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":9.1,"headline":"Sentry: Improper Authentication on SAML SSO process allows user identity linking","id":"CVE-2026-27197","kev_date_added":null,"published":"2026-02-21"},{"cvss_score":8.7,"headline":"Sentry 8.2.0 Remote Code Execution via Pickle Deserialization","id":"CVE-2021-47935","kev_date_added":null,"published":"2026-05-10"},{"cvss_score":8.1,"headline":"Sentry vulnerable to privilege escalation via ApiTokensEndpoint","id":"CVE-2023-39349","kev_date_added":null,"published":"2023-08-07"},{"cvss_score":7.7,"headline":"Sentry vulnerable to improper authorization on debug and artifact file downloads","id":"CVE-2023-36826","kev_date_added":null,"published":"2023-07-25"},{"cvss_score":7.5,"headline":"Sentry: Inefficient Regular Expression Complexity in sentry","id":"CVE-2026-52794","kev_date_added":null,"published":"2026-06-24"},{"cvss_score":7.3,"headline":"Sentry's superuser cleartext password leaked in logs","id":"CVE-2024-32474","kev_date_added":null,"published":"2024-04-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-18","vendors":["getsentry"]},"summary":"Authenticated users can delete alert notifications for other users by exploiting missing authorization checks in Sentry.","url":"https://insights.sbomify.com/CVE-2024-45605/"}