CVE-2024-45606 Improper authorization on muting of alert rules in sentry

High 7.1 Published Updated

Authenticated users can mute alert rules in arbitrary Sentry projects without proper authorization, requiring self-hosted users to upgrade.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-45606?

CVE-2024-45606 is a high-severity missing authorization vulnerability in getsentry sentry, published on 17 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Sentry is a developer-first error tracking and performance monitoring platform. An authenticated user can mute alert rules from arbitrary organizations and projects with a know rule ID. The user does not need to be a member of the organization or have permissions on the project. In our review, we have identified no instances where alerts have been muted by unauthorized parties. A patch was issued to ensure authorization checks are properly scoped on requests to mute alert rules. Authenticated users who do not have the necessary permissions are no longer able to mute alerts. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version **24.9.0** or higher. The rule mute feature was generally available as of 23.6.0 but users with early access may have had the feature as of 23.4.0. Affected users are advised to upgrade to version 24.9.0. There are no known workarounds for this vulnerability.

Weakness: CWE-639

Which versions are affected by CVE-2024-45606?

3 open source packages ship an affected version, including sentry. It affects 1 product.

PackageAffectedFixed in
sentry PyPIFrom 23.4.024.9.0
sentry PyPIFrom 23.4.024.9.0
sentry PyPIFrom 23.4.024.9.0

Products include Sentry Sentry.

How do I fix CVE-2024-45606?

Upgrade sentry to 24.9.0 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-45606 being exploited?

There is no known exploitation of CVE-2024-45606 in the wild and no public exploit code.

Sources

Also known as GHSA-v345-w9f2-mpm5, PYSEC-2026-1916.

Is CVE-2024-45606 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free