# CVE-2024-45606: Improper authorization on muting of alert rules in sentry

> Authenticated users can mute alert rules in arbitrary Sentry projects without proper authorization, requiring self-hosted users to upgrade.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2024
- **Updated:** 18 Sep 2024
- **Also known as:** GHSA-v345-w9f2-mpm5, PYSEC-2026-1916

## What is CVE-2024-45606?

CVE-2024-45606 is a high-severity missing authorization vulnerability in getsentry sentry, published on 17 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Sentry is a developer-first error tracking and performance monitoring platform. An authenticated user can mute alert rules from arbitrary organizations and projects with a know rule ID. The user does not need to be a member of the organization or have permissions on the project.  In our review, we have identified no instances where alerts have been muted by unauthorized parties.  A patch was issued to ensure authorization checks are properly scoped on requests to mute alert rules. Authenticated users who do not have the necessary permissions are no longer able to mute alerts.  Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version **24.9.0** or higher. The rule mute feature was generally available as of 23.6.0 but users with early access may have had the feature as of 23.4.0. Affected users are advised to upgrade to version 24.9.0. There are no known workarounds for this vulnerability.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2024-45606?

3 open source packages ship an affected version, including sentry. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sentry` | PyPI | From 23.4.0 | 24.9.0 |
| `sentry` | PyPI | From 23.4.0 | 24.9.0 |
| `sentry` | PyPI | From 23.4.0 | 24.9.0 |

Products: Sentry Sentry.

## How do I fix CVE-2024-45606?

Upgrade sentry to 24.9.0 or later.

## Is CVE-2024-45606 being exploited?

There is no known exploitation of CVE-2024-45606 in the wild and no public exploit code.

## Other vulnerabilities in getsentry sentry

- [CVE-2026-42354](https://insights.sbomify.com/CVE-2026-42354/): Sentry: Improper authentication on SAML SSO process allows user identity linking (critical 9.1)
- [CVE-2026-27197](https://insights.sbomify.com/CVE-2026-27197/): Sentry: Improper Authentication on SAML SSO process allows user identity linking (critical 9.1)
- [CVE-2021-47935](https://insights.sbomify.com/CVE-2021-47935/): Sentry 8.2.0 Remote Code Execution via Pickle Deserialization (high 8.7)
- [CVE-2023-39349](https://insights.sbomify.com/CVE-2023-39349/): Sentry vulnerable to privilege escalation via ApiTokensEndpoint (high 8.1)
- [CVE-2023-36826](https://insights.sbomify.com/CVE-2023-36826/): Sentry vulnerable to improper authorization on debug and artifact file downloads (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45606 and fix it if it is affected.

What it is: CVE-2024-45606 is a high-severity missing authorization vulnerability in getsentry sentry, published on 17 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-45606 in the wild and no public exploit code.

Affected packages and fixed versions:
- sentry (PyPI): affected from 23.4.0; fixed in 24.9.0
- sentry (PyPI): affected from 23.4.0; fixed in 24.9.0
- sentry (PyPI): affected from 23.4.0; fixed in 24.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45606/ (Markdown: https://insights.sbomify.com/CVE-2024-45606/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45606
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45606
- OSV: https://osv.dev/vulnerability/CVE-2024-45606

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45606/
Summaries are generated and may contain mistakes; the official description above is the record.
