CVE-2024-45607 whatsapp-api-js fails to validate message's signature

Medium 5.8 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2024-45607?

CVE-2024-45607 is a medium-severity vulnerability in Secreto31126 whatsapp-api-js, published on 12 Sep 2024.

Official description

whatsapp-api-js is a TypeScript server agnostic Whatsapp's Official API framework. It's possible to check the payload validation using the WhatsAppAPI.verifyRequestSignature and expect false when the signature is valid. Incorrect Access Control, anyone using the post or verifyRequestSignature methods to handle messages is impacted. This vulnerability is fixed in 4.0.3.

Weakness: CWE-347

Which versions are affected by CVE-2024-45607?

2 open source packages ship an affected version, including whatsapp-api-js. It affects 1 product.

PackageAffectedFixed in
whatsapp-api-js npmFrom 4.0.04.0.3
whatsapp-api-js npmFrom 4.0.04.0.3

Products include Secreto31126 Whatsapp-Api-Js.

How do I fix CVE-2024-45607?

Upgrade whatsapp-api-js to 4.0.3 or later.

Is CVE-2024-45607 being exploited?

There is no known exploitation of CVE-2024-45607 in the wild and no public exploit code.

Sources

Also known as GHSA-mwhf-vhr5-7j23.

Is CVE-2024-45607 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free