# CVE-2024-45607: whatsapp-api-js fails to validate message's signature


- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 12 Sep 2024
- **Updated:** 12 Sep 2024
- **Also known as:** GHSA-mwhf-vhr5-7j23

## What is CVE-2024-45607?

CVE-2024-45607 is a medium-severity vulnerability in Secreto31126 whatsapp-api-js, published on 12 Sep 2024. 

### Official description

whatsapp-api-js is a TypeScript server agnostic Whatsapp's Official API framework. It's possible to check the payload validation using the WhatsAppAPI.verifyRequestSignature and expect false when the signature is valid. Incorrect Access Control, anyone using the post or verifyRequestSignature methods to handle messages is impacted. This vulnerability is fixed in 4.0.3.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2024-45607?

2 open source packages ship an affected version, including whatsapp-api-js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `whatsapp-api-js` | npm | From 4.0.0 | 4.0.3 |
| `whatsapp-api-js` | npm | From 4.0.0 | 4.0.3 |

Products: Secreto31126 Whatsapp-Api-Js.

## How do I fix CVE-2024-45607?

Upgrade whatsapp-api-js to 4.0.3 or later.

## Is CVE-2024-45607 being exploited?

There is no known exploitation of CVE-2024-45607 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45607 and fix it if it is affected.

What it is: CVE-2024-45607 is a medium-severity vulnerability in Secreto31126 whatsapp-api-js, published on 12 Sep 2024. 
Exploitation: There is no known exploitation of CVE-2024-45607 in the wild and no public exploit code.

Affected packages and fixed versions:
- whatsapp-api-js (npm): affected from 4.0.0; fixed in 4.0.3
- whatsapp-api-js (npm): affected from 4.0.0; fixed in 4.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45607/ (Markdown: https://insights.sbomify.com/CVE-2024-45607/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45607
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45607
- OSV: https://osv.dev/vulnerability/CVE-2024-45607

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45607/
Summaries are generated and may contain mistakes; the official description above is the record.
