CVE-2024-45613 CKEditor 5 has Cross-site Scripting vulnerability in the clipboard package

Medium 5.1 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2024-45613?

CVE-2024-45613 is a medium-severity vulnerability in ckeditor5, published on 25 Sep 2024.

Official description

CKEditor 5 is a JavaScript rich-text editor. Starting in version 40.0.0 and prior to version 43.1.1, a Cross-Site Scripting (XSS) vulnerability is present in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability only affects installations where the Block Toolbar plugin is enabled and either the General HTML Support (with a configuration that permits unsafe markup) or the HTML Embed plugin is also enabled. A fix for the problem is available in version 43.1.1. As a workaround, one may disable the block toolbar plugin.

Weakness: CWE-79

Which versions are affected by CVE-2024-45613?

4 open source packages ship an affected version, including @ckeditor/ckeditor5-clipboard and ckeditor5. It affects 1 product.

PackageAffectedFixed in
@ckeditor/ckeditor5-clipboard npmFrom 40.0.043.1.1
@ckeditor/ckeditor5-clipboard npmFrom 40.0.043.1.1
ckeditor5 npmFrom 40.0.043.1.1
ckeditor5 npmFrom 40.0.043.1.1

Products include Ckeditor Ckeditor5.

How do I fix CVE-2024-45613?

Upgrade @ckeditor/ckeditor5-clipboard to 43.1.1 or later.

Is CVE-2024-45613 being exploited?

There is no known exploitation of CVE-2024-45613 in the wild and no public exploit code.

Sources

Also known as GHSA-rgg8-g5x8-wr9v, UBUNTU-CVE-2024-45613.

Is CVE-2024-45613 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free