# CVE-2024-45627: Apache Linkis Metadata Query Service JDBC: JDBC Datasource Module with Mysql has file read vulnerability

> An authenticated attacker can read arbitrary files from the server by configuring malicious MySQL JDBC parameters in the DataSource Manager Module.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jan 2025
- **Updated:** 14 Jan 2025
- **Also known as:** GHSA-8cvq-3jjp-ph9p

## What is CVE-2024-45627?

CVE-2024-45627 is a medium-severity path traversal vulnerability in Apache Linkis Metadata Query Service JDBC, published on 14 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In Apache Linkis <1.7.0, due to the lack of effective filtering
of parameters, an attacker configuring malicious Mysql JDBC parameters in the DataSource Manager Module will 

allow the attacker to read arbitrary files from the Linkis server. Therefore, the parameters in the Mysql JDBC URL should be blacklisted. This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out. Versions of Apache Linkis < 1.7.0 will be affected. 
We recommend users upgrade the version of Linkis to version 1.7.0.

Weakness: CWE-552 (Files or Directories Accessible to External Parties)

## Which versions are affected by CVE-2024-45627?

2 open source packages ship an affected version, including org.apache.linkis:linkis-metadata-query-service-jdbc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.linkis:linkis-metadata-query-service-jdbc` | Maven | From 1.5.0 | 1.7.0 |
| `org.apache.linkis:linkis-metadata-query-service-jdbc` | Maven | From 1.5.0 | 1.7.0 |

Products: Apache Linkis.

## How do I fix CVE-2024-45627?

Upgrade org.apache.linkis:linkis-metadata-query-service-jdbc to 1.7.0 or later.

## Is CVE-2024-45627 being exploited?

There is no known exploitation of CVE-2024-45627 in the wild and no public exploit code.

## Other vulnerabilities in Apache Linkis Metadata Query Service JDBC

- [CVE-2023-27602](https://insights.sbomify.com/CVE-2023-27602/): Apache Linkis publicsercice module unrestricted upload of file (critical 9.8)
- [CVE-2023-27603](https://insights.sbomify.com/CVE-2023-27603/): Apache Linkis Mangaer module engineConn material upload exists Zip Slip issue (critical 9.8)
- [CVE-2023-29215](https://insights.sbomify.com/CVE-2023-29215/): Apache Linkis JDBC EngineCon has a deserialization command execution (critical 9.8)
- [CVE-2023-29216](https://insights.sbomify.com/CVE-2023-29216/): Apache Linkis DatasourceManager module has a deserialization command execution (critical 9.8)
- [CVE-2023-27987](https://insights.sbomify.com/CVE-2023-27987/): Apache Linkis gateway module token authentication bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45627 and fix it if it is affected.

What it is: CVE-2024-45627 is a medium-severity path traversal vulnerability in Apache Linkis Metadata Query Service JDBC, published on 14 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-45627 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.linkis:linkis-metadata-query-service-jdbc (Maven): affected from 1.5.0; fixed in 1.7.0
- org.apache.linkis:linkis-metadata-query-service-jdbc (Maven): affected from 1.5.0; fixed in 1.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45627/ (Markdown: https://insights.sbomify.com/CVE-2024-45627/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45627
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45627
- OSV: https://osv.dev/vulnerability/CVE-2024-45627

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45627/
Summaries are generated and may contain mistakes; the official description above is the record.
