CVE-2024-45689 Moodle: unprotected access to sensitive information via dynamic tables
Attackers can access sensitive information in dynamic tables without proper permission checks, exposing data to unauthorized users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-45689?
CVE-2024-45689 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 20 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A flaw was found in Moodle. Dynamic tables did not enforce capability checks, which resulted in users having the ability to retrieve information they did not have permission to access.
Weakness: CWE-862
Which versions are affected by CVE-2024-45689?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.13 |
moodle/moodle Packagist | All versions | 4.1.13 |
moodle/moodle Packagist | From 4.2.0-beta | 4.2.10 |
moodle/moodle Packagist | From 4.2.0-beta | 4.2.10 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.7 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.7 |
3 more packages
moodle/moodle Packagist | From 4.4.0-beta | 4.4.3 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.3 |
moodle Bitnami | All versions | 4.1.13, 4.2.10, 4.3.7, 4.4.3 |
Products include Moodle Moodle.
How do I fix CVE-2024-45689?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.13, 4.2.10, 4.3.7 or 4.4.3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-45689 being exploited?
There is no known exploitation of CVE-2024-45689 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2024-45689, GHSA-j822-x5gg-5r56, UBUNTU-CVE-2024-45689.