CVE-2024-45690 Moodle: idor when deleting oauth2 linked accounts
Attackers can delete other users' OAuth2-linked accounts due to missing authorization checks in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-45690?
CVE-2024-45690 is a high-severity missing authorization vulnerability in Moodle Moodle, published on 20 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A flaw was found in Moodle. Additional checks were required to ensure users can only delete their OAuth2-linked accounts.
Weakness: CWE-276
Which versions are affected by CVE-2024-45690?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.13 |
moodle/moodle Packagist | All versions | 4.1.13 |
moodle/moodle Packagist | From 4.2.0-beta | 4.2.10 |
moodle/moodle Packagist | From 4.2.0-beta | 4.2.10 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.7 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.7 |
3 more packages
moodle/moodle Packagist | From 4.4.0-beta | 4.4.3 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.3 |
moodle Bitnami | All versions | 4.1.13, 4.2.10, 4.3.7, 4.4.3 |
Products include Moodle Moodle.
How do I fix CVE-2024-45690?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.13, 4.2.10, 4.3.7 or 4.4.3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-45690 being exploited?
There is no known exploitation of CVE-2024-45690 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2024-45690, GHSA-fhg2-r2h9-h7q8, UBUNTU-CVE-2024-45690.