{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-45693 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-45693 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-45693 is a high-severity vulnerability in Apache Cloudstack, published on 16 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-45693 and fix it if it is affected.\n\nWhat it is: CVE-2024-45693 is a high-severity vulnerability in Apache Cloudstack, published on 16 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-45693 in the wild and no public exploit code.\n\nAffected product: Apache Cloudstack. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-45693/ (Markdown: https://insights.sbomify.com/CVE-2024-45693/index.md)","id":"CVE-2024-45693","markdown":"https://insights.sbomify.com/CVE-2024-45693/index.md","name":"CVE-2024-45693","record":{"aliases":["GHSA-gvwv-wfjf-rvm7"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["account_takeover","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"CloudStack management UI","requires_auth":"none","summary":"Attackers can trick authenticated users into submitting malicious requests, leading to account takeover and resource compromise in Apache CloudStack.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"cloudstack","vendor":"apache"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Users logged into the Apache CloudStack's web interface can be tricked to submit malicious CSRF requests due to missing validation of the origin of the requests. This can allow an attacker to gain privileges and access to resources of the authenticated users and may lead to account takeover, disruption, exposure of sensitive data and compromise integrity of the resources owned by the user account that are managed by the platform.\n\nThis issue affects Apache CloudStack from 4.15.1.0 through 4.18.2.3 and 4.19.0.0 through 4.19.1.1\n\nUsers are recommended to upgrade to Apache CloudStack 4.18.2.4 or 4.19.1.2, or later, which addresses this issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Apache CloudStack: Request origin validation bypass makes account takeover possible","id":"CVE-2024-45693","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"apache:cloudstack","products":["apache:cloudstack"],"type":"csrf","year":"2024"},"n_packages":0,"n_references":3,"next":{"headline":"D-Link WiFi router - Stack-based Buffer Overflow","id":"CVE-2024-45694"},"packages":[],"prev":{"headline":"Denial of service in n/a","id":"CVE-2024-45692"},"products":["Apache CloudStack"],"published":"2024-10-16","related":[{"cvss_score":10,"headline":"Missing authorization in n/a","id":"CVE-2012-4501","kev_date_added":null,"published":"2012-10-26"},{"cvss_score":9.8,"headline":"Apache CloudStack: Unauthenticated cluster service port leads to remote execution","id":"CVE-2024-38346","kev_date_added":null,"published":"2024-07-05"},{"cvss_score":9.8,"headline":"Apache CloudStack: Integration API service uses dynamic port when disabled","id":"CVE-2024-39864","kev_date_added":null,"published":"2024-07-05"},{"cvss_score":9.8,"headline":"Apache CloudStack: x-forwarded-for HTTP header parsed by default","id":"CVE-2024-29006","kev_date_added":null,"published":"2024-04-04"},{"cvss_score":9.8,"headline":"Apache CloudStack SAML Single Sign-On XXE","id":"CVE-2022-35741","kev_date_added":null,"published":"2022-07-18"},{"cvss_score":9.8,"headline":"Command injection in Apache CloudStack","id":"CVE-2019-17562","kev_date_added":null,"published":"2020-05-14"},{"cvss_score":9.8,"headline":"Missing authorization in Apache CloudStack","id":"CVE-2016-6813","kev_date_added":null,"published":"2018-02-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-16","vendors":["Apache Software Foundation"]},"summary":"Attackers can trick authenticated users into submitting malicious requests, leading to account takeover and resource compromise in Apache CloudStack.","url":"https://insights.sbomify.com/CVE-2024-45693/"}