CVE-2024-45719 Apache Answer: Predictable Authorization Token Using UUIDv1

Low 2.6 Published Updated

Attackers can predict authorization tokens due to weak UUIDv1 generation, potentially bypassing security controls in Apache Answer.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-45719?

CVE-2024-45719 is a low-severity vulnerability in Apache Answer, published on 22 Nov 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Inadequate Encryption Strength vulnerability in Apache Answer.

This issue affects Apache Answer: through 1.4.0.

The ids generated using the UUID v1 version are to some extent not secure enough. It can cause the generated token to be predictable. Users are recommended to upgrade to version 1.4.1, which fixes the issue.

Weakness: CWE-326

Which versions are affected by CVE-2024-45719?

3 open source packages ship an affected version, including github.com/apache/incubator-answer. It affects 1 product.

PackageAffectedFixed in
github.com/apache/incubator-answer GoAll versions1.4.1
github.com/apache/incubator-answer GoAll versions1.4.1
github.com/apache/incubator-answer GoAll versions1.4.1

Products include Apache Answer.

How do I fix CVE-2024-45719?

Upgrade github.com/apache/incubator-answer to 1.4.1 or later.

Is CVE-2024-45719 being exploited?

There is no known exploitation of CVE-2024-45719 in the wild and no public exploit code.

Sources

Also known as GHSA-mr95-vfcf-fx9p, GO-2024-3287.

Is CVE-2024-45719 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free