# CVE-2024-45719: Apache Answer: Predictable Authorization Token Using UUIDv1

> Attackers can predict authorization tokens due to weak UUIDv1 generation, potentially bypassing security controls in Apache Answer.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Nov 2024
- **Updated:** 22 Nov 2024
- **Also known as:** GHSA-mr95-vfcf-fx9p, GO-2024-3287

## What is CVE-2024-45719?

CVE-2024-45719 is a low-severity vulnerability in Apache Answer, published on 22 Nov 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Inadequate Encryption Strength vulnerability in Apache Answer.

This issue affects Apache Answer: through 1.4.0.

The ids generated using the UUID v1 version are to some extent not secure enough. It can cause the generated token to be predictable.
Users are recommended to upgrade to version 1.4.1, which fixes the issue.

Weakness: CWE-326 (Inadequate Encryption Strength)

## Which versions are affected by CVE-2024-45719?

3 open source packages ship an affected version, including github.com/apache/incubator-answer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/apache/incubator-answer` | Go | All versions | 1.4.1 |
| `github.com/apache/incubator-answer` | Go | All versions | 1.4.1 |
| `github.com/apache/incubator-answer` | Go | All versions | 1.4.1 |

Products: Apache Answer.

## How do I fix CVE-2024-45719?

Upgrade github.com/apache/incubator-answer to 1.4.1 or later.

## Is CVE-2024-45719 being exploited?

There is no known exploitation of CVE-2024-45719 in the wild and no public exploit code.

## Other vulnerabilities in Apache Answer

- [CVE-2026-60053](https://insights.sbomify.com/CVE-2026-60053/): Apache Answer: Residual Administrative API Key Access After Role or Account Revocation (critical 9.1)
- [CVE-2024-22393](https://insights.sbomify.com/CVE-2024-22393/): Apache Answer: Pixel Flood Attack by uploading the large pixel file (critical 9.1)
- [CVE-2026-48834](https://insights.sbomify.com/CVE-2026-48834/): Apache Answer: Denial of service via crafted Accept-Language header parsing (high 7.5)
- [CVE-2026-48911](https://insights.sbomify.com/CVE-2026-48911/): Apache Answer: Unauthenticated OAuth Email-Binding Account Takeover via Existing User Confirmation Flow (high 7.5)
- [CVE-2026-60023](https://insights.sbomify.com/CVE-2026-60023/): Apache Answer: Unauthorized disclosure of deleted or pending answer content (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45719 and fix it if it is affected.

What it is: CVE-2024-45719 is a low-severity vulnerability in Apache Answer, published on 22 Nov 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-45719 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/apache/incubator-answer (Go): affected all versions; fixed in 1.4.1
- github.com/apache/incubator-answer (Go): affected all versions; fixed in 1.4.1
- github.com/apache/incubator-answer (Go): affected all versions; fixed in 1.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45719/ (Markdown: https://insights.sbomify.com/CVE-2024-45719/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45719
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45719
- OSV: https://osv.dev/vulnerability/CVE-2024-45719

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45719/
Summaries are generated and may contain mistakes; the official description above is the record.
