{"answers":{"affected":"1 open source package ship an affected version, including subversion. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-45720 in the wild and no public exploit code.","fix":"Upgrade subversion to 1.14.4 or later.","what":"CVE-2024-45720 is a high-severity command injection vulnerability in Apache Subversion, published on 9 Oct 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-45720 and fix it if it is affected.\n\nWhat it is: CVE-2024-45720 is a high-severity command injection vulnerability in Apache Subversion, published on 9 Oct 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-45720 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- subversion (Bitnami): affected from 1.0.0; fixed in 1.14.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-45720/ (Markdown: https://insights.sbomify.com/CVE-2024-45720/index.md)","id":"CVE-2024-45720","markdown":"https://insights.sbomify.com/CVE-2024-45720/index.md","name":"CVE-2024-45720","record":{"aliases":["ALPINE-CVE-2024-45720","BELL-CVE-2024-45720","BIT-subversion-2024-45720","GHSA-86vm-fj76-qh69"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Subversion client","requires_auth":"low_privilege","summary":"Attackers can inject command line arguments on Windows to execute arbitrary programs via crafted strings in Subversion.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"subversion","vendor":"apache"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"On Windows platforms, a \"best fit\" character encoding conversion of command line arguments to Subversion's executables (e.g., svn.exe, etc.) may lead to unexpected command line argument interpretation, including argument injection and execution of other programs, if a specially crafted command line argument string is processed.\n\nAll versions of Subversion up to and including Subversion 1.14.3 are affected on Windows platforms only. Users are recommended to upgrade to version Subversion 1.14.4, which fixes this issue.\n\nSubversion is not affected on UNIX-like platforms.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Subversion: Command line argument injection on Windows platforms","id":"CVE-2024-45720","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"command_injection","year":"2024"},"n_packages":1,"n_references":1,"next":{"headline":"Command injection in Wi-Fi STATION SH-52B","id":"CVE-2024-45721"},"packages":[{"ecosystem":"Bitnami","fixed":["1.14.4"],"introduced":["1.0.0"],"last_affected":[],"package":"subversion","purl":"pkg:bitnami/subversion","source":"BIT-subversion-2024-45720"}],"prev":{"headline":"Apache Answer: Predictable Authorization Token Using UUIDv1","id":"CVE-2024-45719"},"products":["Apache Subversion"],"published":"2024-10-09","related":[{"cvss_score":9.8,"headline":"A maliciously constructed svn+ssh:// URL would cause Subversion clients before 1.8.19, 1.9.x before 1.9.7, and 1.10.0.x through 1.10.0-alpha","id":"CVE-2017-9800","kev_date_added":null,"published":"2017-08-11"},{"cvss_score":8.8,"headline":"Denial of service in n/a","id":"CVE-2013-4246","kev_date_added":null,"published":"2017-10-30"},{"cvss_score":8.6,"headline":"Integer overflow in n/a","id":"CVE-2015-5259","kev_date_added":null,"published":"2016-01-08"},{"cvss_score":7.8,"headline":"Denial of service in n/a","id":"CVE-2015-0202","kev_date_added":null,"published":"2015-04-08"},{"cvss_score":7.8,"headline":"Denial of service in n/a","id":"CVE-2013-2112","kev_date_added":null,"published":"2013-07-31"},{"cvss_score":7.6,"headline":"Integer overflow in n/a","id":"CVE-2015-5343","kev_date_added":null,"published":"2016-04-14"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-09","vendors":["Apache Software Foundation"]},"summary":"Attackers can inject command line arguments on Windows to execute arbitrary programs via crafted strings in Subversion.","url":"https://insights.sbomify.com/CVE-2024-45720/"}