# CVE-2024-45720: Apache Subversion: Command line argument injection on Windows platforms

> Attackers can inject command line arguments on Windows to execute arbitrary programs via crafted strings in Subversion.

- **Severity:** High 8.2 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Oct 2024
- **Updated:** 9 Oct 2024
- **Also known as:** ALPINE-CVE-2024-45720, BELL-CVE-2024-45720, BIT-subversion-2024-45720, GHSA-86vm-fj76-qh69

## What is CVE-2024-45720?

CVE-2024-45720 is a high-severity command injection vulnerability in Apache Subversion, published on 9 Oct 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

On Windows platforms, a "best fit" character encoding conversion of command line arguments to Subversion's executables (e.g., svn.exe, etc.) may lead to unexpected command line argument interpretation, including argument injection and execution of other programs, if a specially crafted command line argument string is processed.

All versions of Subversion up to and including Subversion 1.14.3 are affected on Windows platforms only. Users are recommended to upgrade to version Subversion 1.14.4, which fixes this issue.

Subversion is not affected on UNIX-like platforms.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2024-45720?

1 open source package ship an affected version, including subversion. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `subversion` | Bitnami | From 1.0.0 | 1.14.4 |

Products: Apache Subversion.

## How do I fix CVE-2024-45720?

Upgrade subversion to 1.14.4 or later.

## Is CVE-2024-45720 being exploited?

There is no known exploitation of CVE-2024-45720 in the wild and no public exploit code.

## Other vulnerabilities in Apache Subversion

- [CVE-2017-9800](https://insights.sbomify.com/CVE-2017-9800/): A maliciously constructed svn+ssh:// URL would cause Subversion clients before 1.8.19, 1.9.x before 1.9.7, and 1.10.0.x through 1.10.0-alpha (critical 9.8)
- [CVE-2013-4246](https://insights.sbomify.com/CVE-2013-4246/): Denial of service in n/a (high 8.8)
- [CVE-2015-5259](https://insights.sbomify.com/CVE-2015-5259/): Integer overflow in n/a (high 8.6)
- [CVE-2015-0202](https://insights.sbomify.com/CVE-2015-0202/): Denial of service in n/a (high 7.8)
- [CVE-2013-2112](https://insights.sbomify.com/CVE-2013-2112/): Denial of service in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45720 and fix it if it is affected.

What it is: CVE-2024-45720 is a high-severity command injection vulnerability in Apache Subversion, published on 9 Oct 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-45720 in the wild and no public exploit code.

Affected packages and fixed versions:
- subversion (Bitnami): affected from 1.0.0; fixed in 1.14.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45720/ (Markdown: https://insights.sbomify.com/CVE-2024-45720/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45720
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45720
- OSV: https://osv.dev/vulnerability/CVE-2024-45720

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45720/
Summaries are generated and may contain mistakes; the official description above is the record.
