CVE-2024-45772 Apache Lucene Replicator: Security Vulnerability in Lucene Replicator - Deserialization Issue

Medium 5.1 Published Updated

Attackers can execute arbitrary code via deserialization in Apache Lucene Replicator if a network-accessible HTTP implementation is deployed.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2024-45772?

CVE-2024-45772 is a medium-severity unsafe deserialization vulnerability in Apache Lucene Replicator, published on 30 Sep 2024. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Deserialization of Untrusted Data vulnerability in Apache Lucene Replicator.

This issue affects Apache Lucene's replicator module: from 4.4.0 before 9.12.0. The deprecated org.apache.lucene.replicator.http package is affected. The org.apache.lucene.replicator.nrt package is not affected.

Users are recommended to upgrade to version 9.12.0, which fixes the issue.

The deserialization can only be triggered if users actively deploy an network-accessible implementation and a corresponding client using a HTTP library that uses the API (e.g., a custom servlet and HTTPClient). Java serialization filters (such as -Djdk.serialFilter='!*' on the commandline) can mitigate the issue on vulnerable versions without impacting functionality.

Weakness: CWE-502

Which versions are affected by CVE-2024-45772?

2 open source packages ship an affected version, including org.apache.lucene:lucene-replicator. It affects 1 product.

PackageAffectedFixed in
org.apache.lucene:lucene-replicator MavenFrom 4.4.09.12.0
org.apache.lucene:lucene-replicator MavenFrom 4.4.09.12.0

Products include Apache Lucene Replicator.

How do I fix CVE-2024-45772?

Upgrade org.apache.lucene:lucene-replicator to 9.12.0 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2024-45772 being exploited?

There is no known exploitation of CVE-2024-45772 in the wild and no public exploit code.

Sources

Also known as GHSA-g643-xq6w-r67c.

Is CVE-2024-45772 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free