{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.lucene:lucene-replicator. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-45772 in the wild and no public exploit code.","fix":"Upgrade org.apache.lucene:lucene-replicator to 9.12.0 or later.","what":"CVE-2024-45772 is a medium-severity unsafe deserialization vulnerability in Apache Lucene Replicator, published on 30 Sep 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-45772 and fix it if it is affected.\n\nWhat it is: CVE-2024-45772 is a medium-severity unsafe deserialization vulnerability in Apache Lucene Replicator, published on 30 Sep 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-45772 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.lucene:lucene-replicator (Maven): affected from 4.4.0; fixed in 9.12.0\n- org.apache.lucene:lucene-replicator (Maven): affected from 4.4.0; fixed in 9.12.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-45772/ (Markdown: https://insights.sbomify.com/CVE-2024-45772/index.md)","id":"CVE-2024-45772","markdown":"https://insights.sbomify.com/CVE-2024-45772/index.md","name":"CVE-2024-45772","record":{"aliases":["GHSA-g643-xq6w-r67c"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Java search library","requires_auth":"high_privilege","summary":"Attackers can execute arbitrary code via deserialization in Apache Lucene Replicator if a network-accessible HTTP implementation is deployed.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"lucene_replicator","vendor":"apache"}],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Deserialization of Untrusted Data vulnerability in Apache Lucene Replicator.\n\nThis issue affects Apache Lucene's replicator module: from 4.4.0 before 9.12.0.\nThe deprecated org.apache.lucene.replicator.http package is affected.\nThe org.apache.lucene.replicator.nrt package is not affected.\n\nUsers are recommended to upgrade to version 9.12.0, which fixes the issue.\n\n The deserialization can only be triggered if users actively deploy an network-accessible implementation and a corresponding client using a HTTP library that uses the API (e.g., a custom servlet and HTTPClient). Java serialization filters (such as -Djdk.serialFilter='!*' on the commandline) can mitigate the issue on vulnerable versions without impacting functionality.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Lucene Replicator: Security Vulnerability in Lucene Replicator - Deserialization Issue","id":"CVE-2024-45772","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"Use after free in Facebook Thrift","id":"CVE-2024-45773"},"packages":[{"ecosystem":"Maven","fixed":["9.12.0"],"introduced":["4.4.0"],"last_affected":[],"package":"org.apache.lucene:lucene-replicator","purl":null,"source":"GHSA-g643-xq6w-r67c"},{"ecosystem":"Maven","fixed":["9.12.0"],"introduced":["4.4.0"],"last_affected":[],"package":"org.apache.lucene:lucene-replicator","purl":"pkg:maven/org.apache.lucene/lucene-replicator","source":"GHSA-g643-xq6w-r67c"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2024-45771"},"products":["Apache Lucene Replicator"],"published":"2024-09-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-12","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute arbitrary code via deserialization in Apache Lucene Replicator if a network-accessible HTTP implementation is deployed.","url":"https://insights.sbomify.com/CVE-2024-45772/"}