# CVE-2024-45784: Apache Airflow: Sensitive configuration values are not masked in the logs by default

> Attackers can view sensitive configuration secrets in task logs, exposing critical data to unauthorized users.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Nov 2024
- **Updated:** 15 Nov 2024
- **Also known as:** BIT-airflow-2024-45784, GHSA-46c3-5xc5-wwhv, PYSEC-2024-182, PYSEC-2026-1112

## What is CVE-2024-45784?

CVE-2024-45784 is a high-severity vulnerability in Apache Airflow, published on 15 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Airflow versions before 2.10.3 contain a vulnerability that could expose sensitive configuration variables in task logs. This vulnerability allows DAG authors to unintentionally or intentionally log sensitive configuration variables. Unauthorized users could access these logs, potentially exposing critical data that could be exploited to compromise the security of the Airflow deployment. In version 2.10.3, secrets are now masked in task logs to prevent sensitive configuration variables from being exposed in the logging output. Users should upgrade to Airflow 2.10.3 or the latest version to eliminate this vulnerability. If you suspect that DAG authors could have logged the secret values to the logs and that your logs are not additionally protected, it is also recommended that you update those secrets.

Weakness: CWE-1295 (Debug Messages Revealing Unnecessary Information)

## Which versions are affected by CVE-2024-45784?

5 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.10.3 |
| `airflow` | Bitnami | All versions | 2.10.3 |
| `airflow` | PyPI | All versions | 2.10.3 |
| `airflow` | PyPI | All versions | 2.10.3 |
| `airflow` | PyPI | All versions | 2.10.3 |

Products: Apache Airflow.

## How do I fix CVE-2024-45784?

Upgrade apache-airflow to 2.10.3 or later.

## Is CVE-2024-45784 being exploited?

There is no known exploitation of CVE-2024-45784 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45784 and fix it if it is affected.

What it is: CVE-2024-45784 is a high-severity vulnerability in Apache Airflow, published on 15 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-45784 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.10.3
- airflow (Bitnami): affected all versions; fixed in 2.10.3
- airflow (PyPI): affected all versions; fixed in 2.10.3
- airflow (PyPI): affected all versions; fixed in 2.10.3
- airflow (PyPI): affected all versions; fixed in 2.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45784/ (Markdown: https://insights.sbomify.com/CVE-2024-45784/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45784
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45784
- OSV: https://osv.dev/vulnerability/CVE-2024-45784

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45784/
Summaries are generated and may contain mistakes; the official description above is the record.
