{"answers":{"affected":"3 open source packages ship an affected version, including confidant.","exploited":"There is no known exploitation of CVE-2024-45793 in the wild and no public exploit code.","fix":"Upgrade confidant to 6.6.2 or later.","what":"CVE-2024-45793 is a medium-severity cross-site scripting vulnerability in lyft confidant, published on 20 Sep 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-45793 and fix it if it is affected.\n\nWhat it is: CVE-2024-45793 is a medium-severity cross-site scripting vulnerability in lyft confidant, published on 20 Sep 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-45793 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- confidant (PyPI): affected all versions; fixed in 6.6.2\n- confidant (PyPI): affected all versions; fixed in 6.6.2\n- confidant (PyPI): affected all versions; fixed in 6.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-45793/ (Markdown: https://insights.sbomify.com/CVE-2024-45793/index.md)","id":"CVE-2024-45793","markdown":"https://insights.sbomify.com/CVE-2024-45793/index.md","name":"CVE-2024-45793","record":{"aliases":["GHSA-rxq8-q85f-m866","PYSEC-2026-1269"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Confidant secret manager","requires_auth":"low_privilege","summary":"Authenticated attackers can inject scripts into Confidant credential and service endpoints, potentially executing code or stealing data from other users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Confidant is a open source secret management service that provides user-friendly storage and access to secrets. The following endpoints are subject to a cross site scripting vulnerability: GET /v1/credentials, GET /v1/credentials/, GET /v1/archive/credentials/, GET /v1/archive/credentials, POST /v1/credentials, PUT /v1/credentials/, PUT /v1/credentials//\u003cto_revision\u003e, GET /v1/services, GET /v1/services/, GET /v1/archive/services/, GET /v1/archive/services, PUT /v1/services/, PUT /v1/services//\u003cto_revision\u003e. The attacker needs to be authenticated and have privileges to create new credentials, but could use this to show information and run scripts to other users into the same Confidant instance. This issue has been patched in version 6.6.2. All users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting from in Confidant API call","id":"CVE-2024-45793","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":3,"n_references":4,"next":{"headline":"SQL Injection in CreateUser API in devtron","id":"CVE-2024-45794"},"packages":[{"ecosystem":"PyPI","fixed":["6.6.2"],"introduced":["0"],"last_affected":[],"package":"confidant","purl":null,"source":"GHSA-rxq8-q85f-m866"},{"ecosystem":"PyPI","fixed":["6.6.2"],"introduced":["0"],"last_affected":[],"package":"confidant","purl":"pkg:pypi/confidant","source":"GHSA-rxq8-q85f-m866"},{"ecosystem":"PyPI","fixed":["6.6.2"],"introduced":["0"],"last_affected":[],"package":"confidant","purl":"pkg:pypi/confidant","source":"PYSEC-2026-1269"}],"prev":{"headline":"MantisBT vulnerable to information disclosure with user profiles","id":"CVE-2024-45792"},"products":["confidant"],"published":"2024-09-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-20","vendors":["lyft"]},"summary":"Authenticated attackers can inject scripts into Confidant credential and service endpoints, potentially executing code or stealing data from other users.","url":"https://insights.sbomify.com/CVE-2024-45793/"}