# CVE-2024-45793: Cross-site Scripting from in Confidant API call

> Authenticated attackers can inject scripts into Confidant credential and service endpoints, potentially executing code or stealing data from other users.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Sep 2024
- **Updated:** 20 Sep 2024
- **Also known as:** GHSA-rxq8-q85f-m866, PYSEC-2026-1269

## What is CVE-2024-45793?

CVE-2024-45793 is a medium-severity cross-site scripting vulnerability in lyft confidant, published on 20 Sep 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Confidant is a open source secret management service that provides user-friendly storage and access to secrets. The following endpoints are subject to a cross site scripting vulnerability: GET /v1/credentials, GET /v1/credentials/, GET /v1/archive/credentials/, GET /v1/archive/credentials, POST /v1/credentials, PUT /v1/credentials/, PUT /v1/credentials//<to_revision>, GET /v1/services, GET /v1/services/, GET /v1/archive/services/, GET /v1/archive/services, PUT /v1/services/, PUT /v1/services//<to_revision>. The attacker needs to be authenticated and have privileges to create new credentials, but could use this to show information and run scripts to other users into the same Confidant instance. This issue has been patched in version 6.6.2. All users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-45793?

3 open source packages ship an affected version, including confidant.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `confidant` | PyPI | All versions | 6.6.2 |
| `confidant` | PyPI | All versions | 6.6.2 |
| `confidant` | PyPI | All versions | 6.6.2 |

## How do I fix CVE-2024-45793?

Upgrade confidant to 6.6.2 or later.

## Is CVE-2024-45793 being exploited?

There is no known exploitation of CVE-2024-45793 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45793 and fix it if it is affected.

What it is: CVE-2024-45793 is a medium-severity cross-site scripting vulnerability in lyft confidant, published on 20 Sep 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-45793 in the wild and no public exploit code.

Affected packages and fixed versions:
- confidant (PyPI): affected all versions; fixed in 6.6.2
- confidant (PyPI): affected all versions; fixed in 6.6.2
- confidant (PyPI): affected all versions; fixed in 6.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45793/ (Markdown: https://insights.sbomify.com/CVE-2024-45793/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45793
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45793
- OSV: https://osv.dev/vulnerability/CVE-2024-45793

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45793/
Summaries are generated and may contain mistakes; the official description above is the record.
