{"answers":{"affected":"1 open source package ship an affected version, including envoy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-45807 in the wild and no public exploit code.","fix":"Upgrade envoy to 1.31.2 or later.","what":"CVE-2024-45807 is a high-severity denial of service vulnerability in Envoyproxy Envoy, published on 19 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-45807 and fix it if it is affected.\n\nWhat it is: CVE-2024-45807 is a high-severity denial of service vulnerability in Envoyproxy Envoy, published on 19 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-45807 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- envoy (Bitnami): affected from 1.31.0; fixed in 1.31.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-45807/ (Markdown: https://insights.sbomify.com/CVE-2024-45807/index.md)","id":"CVE-2024-45807","markdown":"https://insights.sbomify.com/CVE-2024-45807/index.md","name":"CVE-2024-45807","record":{"aliases":["BIT-envoy-2024-45807","GHSA-qc52-r4x5-9w37"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Envoy proxy","requires_auth":"none","summary":"A bug in Envoy's oghttp2 codec causes crashes during stream management, requiring an upgrade to restore service availability.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"envoy","vendor":"envoyproxy"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-670","name":"Always-Incorrect Control Flow Implementation"}],"description":"Envoy is a cloud-native high-performance edge/middle/service proxy. Envoy's 1.31 is using `oghttp` as the default HTTP/2 codec, and there are potential bugs around stream management in the codec. To resolve this Envoy will switch off the `oghttp2` by default. The impact of this issue is that envoy will crash. This issue has been addressed in release version 1.31.2. All users are advised to upgrade. There are no known workarounds for this issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"oghttp2 crash on OnBeginHeadersForStream in envoy","id":"CVE-2024-45807","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"envoyproxy:envoy","products":["envoyproxy:envoy"],"type":"denial_of_service","year":"2024"},"n_packages":1,"n_references":1,"next":{"headline":"Malicious log injection via access logs in envoy","id":"CVE-2024-45808"},"packages":[{"ecosystem":"Bitnami","fixed":["1.31.2"],"introduced":["1.31.0"],"last_affected":[],"package":"envoy","purl":"pkg:bitnami/envoy","source":"BIT-envoy-2024-45807"}],"prev":{"headline":"Potential manipulate `x-envoy` headers from external sources in envoy","id":"CVE-2024-45806"},"products":["envoy"],"published":"2024-09-19","related":[{"cvss_score":10,"headline":"Trivial authentication bypass in Envoy","id":"CVE-2022-29226","kev_date_added":null,"published":"2022-06-09"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2019-18801","kev_date_added":null,"published":"2019-12-13"},{"cvss_score":9.8,"headline":"Security feature bypass in n/a","id":"CVE-2019-18802","kev_date_added":null,"published":"2019-12-13"},{"cvss_score":8.8,"headline":"Information disclosure in n/a","id":"CVE-2020-35470","kev_date_added":null,"published":"2020-12-15"},{"cvss_score":8.6,"headline":"Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata","id":"CVE-2024-23324","kev_date_added":null,"published":"2024-02-09"},{"cvss_score":8.6,"headline":"Envoy vulnerable to OAuth2 credentials exploit with permanent validity","id":"CVE-2023-35941","kev_date_added":null,"published":"2023-07-25"},{"cvss_score":8.6,"headline":"Incorrect handling of H2 GOAWAY + SETTINGS frames","id":"CVE-2021-39162","kev_date_added":null,"published":"2021-09-09"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-20","vendors":["envoyproxy"]},"summary":"A bug in Envoy's oghttp2 codec causes crashes during stream management, requiring an upgrade to restore service availability.","url":"https://insights.sbomify.com/CVE-2024-45807/"}