# CVE-2024-45807: oghttp2 crash on OnBeginHeadersForStream in envoy

> A bug in Envoy's oghttp2 codec causes crashes during stream management, requiring an upgrade to restore service availability.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Sep 2024
- **Updated:** 20 Sep 2024
- **Also known as:** BIT-envoy-2024-45807, GHSA-qc52-r4x5-9w37

## What is CVE-2024-45807?

CVE-2024-45807 is a high-severity denial of service vulnerability in Envoyproxy Envoy, published on 19 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Envoy is a cloud-native high-performance edge/middle/service proxy. Envoy's 1.31 is using `oghttp` as the default HTTP/2 codec, and there are potential bugs around stream management in the codec. To resolve this Envoy will switch off the `oghttp2` by default. The impact of this issue is that envoy will crash. This issue has been addressed in release version 1.31.2. All users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-670 (Always-Incorrect Control Flow Implementation)

## Which versions are affected by CVE-2024-45807?

1 open source package ship an affected version, including envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | From 1.31.0 | 1.31.2 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2024-45807?

Upgrade envoy to 1.31.2 or later.

## Is CVE-2024-45807 being exploited?

There is no known exploitation of CVE-2024-45807 in the wild and no public exploit code.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45807 and fix it if it is affected.

What it is: CVE-2024-45807 is a high-severity denial of service vulnerability in Envoyproxy Envoy, published on 19 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-45807 in the wild and no public exploit code.

Affected packages and fixed versions:
- envoy (Bitnami): affected from 1.31.0; fixed in 1.31.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45807/ (Markdown: https://insights.sbomify.com/CVE-2024-45807/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45807
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45807
- OSV: https://osv.dev/vulnerability/CVE-2024-45807

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45807/
Summaries are generated and may contain mistakes; the official description above is the record.
