# CVE-2024-45815: Prototype pollution in @backstage/plugin-catalog-backend

> Authenticated attackers can cause denial of service in Backstage catalog backend via prototype pollution in crafted API queries.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2024
- **Updated:** 18 Sep 2024
- **Also known as:** GHSA-3x3f-jcp3-g22j

## What is CVE-2024-45815?

CVE-2024-45815 is a medium-severity vulnerability in Linuxfoundation Backstage, published on 17 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. A malicious actor with authenticated access to a Backstage instance with the catalog backend plugin installed is able to interrupt the service using a specially crafted query to the catalog API. This has been fixed in the `1.26.0` release of the `@backstage/plugin-catalog-backend`. All users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2024-45815?

2 open source packages ship an affected version, including @backstage/plugin-catalog-backend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-catalog-backend` | npm | All versions | 1.26.0 |
| `@backstage/plugin-catalog-backend` | npm | All versions | 1.26.0 |

Products: Linuxfoundation Backstage.

## How do I fix CVE-2024-45815?

Upgrade @backstage/plugin-catalog-backend to 1.26.0 or later.

## Is CVE-2024-45815 being exploited?

There is no known exploitation of CVE-2024-45815 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45815 and fix it if it is affected.

What it is: CVE-2024-45815 is a medium-severity vulnerability in Linuxfoundation Backstage, published on 17 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-45815 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-catalog-backend (npm): affected all versions; fixed in 1.26.0
- @backstage/plugin-catalog-backend (npm): affected all versions; fixed in 1.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45815/ (Markdown: https://insights.sbomify.com/CVE-2024-45815/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45815
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45815
- OSV: https://osv.dev/vulnerability/CVE-2024-45815

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45815/
Summaries are generated and may contain mistakes; the official description above is the record.
