# CVE-2024-45816: Storage bucket Directory Traversal in @backstage/plugin-techdocs-backend

> Attackers can access unauthorized files in S3 or GCS buckets and bypass permission checks when using specific storage providers.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2024
- **Updated:** 18 Sep 2024
- **Also known as:** GHSA-39v3-f278-vj3g

## What is CVE-2024-45816?

CVE-2024-45816 is a medium-severity path traversal vulnerability in Linuxfoundation Backstage, published on 17 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. When using the AWS S3 or GCS storage provider for TechDocs it is possible to access content in the entire storage bucket. This can leak contents of the bucket that are not intended to be accessible, as well as bypass permission checks in Backstage. This has been fixed in the 1.10.13 release of the `@backstage/plugin-techdocs-backend` package. All users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2024-45816?

2 open source packages ship an affected version, including @backstage/plugin-techdocs-backend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-techdocs-backend` | npm | All versions | 1.10.13 |
| `@backstage/plugin-techdocs-backend` | npm | All versions | 1.10.13 |

Products: Linuxfoundation Backstage.

## How do I fix CVE-2024-45816?

Upgrade @backstage/plugin-techdocs-backend to 1.10.13 or later.

## Is CVE-2024-45816 being exploited?

There is no known exploitation of CVE-2024-45816 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45816 and fix it if it is affected.

What it is: CVE-2024-45816 is a medium-severity path traversal vulnerability in Linuxfoundation Backstage, published on 17 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-45816 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-techdocs-backend (npm): affected all versions; fixed in 1.10.13
- @backstage/plugin-techdocs-backend (npm): affected all versions; fixed in 1.10.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45816/ (Markdown: https://insights.sbomify.com/CVE-2024-45816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45816
- OSV: https://osv.dev/vulnerability/CVE-2024-45816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45816/
Summaries are generated and may contain mistakes; the official description above is the record.
