CVE-2024-45843 Weak SSRF Filtering
Attackers can exploit weak SSRF filtering in Mattermost deployed on Oracle Cloud or Alibaba to access internal metadata endpoints.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-45843?
CVE-2024-45843 is a low-severity server-side request forgery vulnerability in Mattermost Mattermost Server, published on 26 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 9.5.x <= 9.5.8 fail to include the metadata endpoints of Oracle Cloud and Alibaba in the SSRF denylist, which allows an attacker to possibly cause an SSRF if Mattermost was deployed in Oracle Cloud or Alibaba.
Weakness: CWE-918
Which versions are affected by CVE-2024-45843?
1 open source package ship an affected version, including mattermost. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mattermost Bitnami | From 9.5.0 | 9.5.9 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2024-45843?
Upgrade mattermost to 9.5.9 or later.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2024-45843 being exploited?
There is no known exploitation of CVE-2024-45843 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as BIT-mattermost-2024-45843, GHSA-w37h-c34c-gwjm.