{"answers":{"affected":"3 open source packages ship an affected version, including guardrails-ai.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45858 exists.","fix":"Upgrade guardrails-ai to 0.5.10 or later.","what":"CVE-2024-45858 is a high-severity code injection vulnerability in guardrails, published on 18 Sep 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-45858 and fix it if it is affected.\n\nWhat it is: CVE-2024-45858 is a high-severity code injection vulnerability in guardrails, published on 18 Sep 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45858 exists.\n\nAffected packages and fixed versions:\n- guardrails-ai (PyPI): affected from 0.2.9; fixed in 0.5.10\n- guardrails-ai (PyPI): affected from 0.2.9; fixed in 0.5.10\n- guardrails-ai (PyPI): affected from 0.2.9; fixed in 0.5.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-45858/ (Markdown: https://insights.sbomify.com/CVE-2024-45858/index.md)","id":"CVE-2024-45858","markdown":"https://insights.sbomify.com/CVE-2024-45858/index.md","name":"CVE-2024-45858","record":{"aliases":["GHSA-w392-75q8-vr67","PYSEC-2026-1432"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Guardrails AI framework","requires_auth":"none","summary":"Attackers can execute arbitrary code on user machines by tricking them into loading malicious XML files processed by the Guardrails AI framework.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"HiddenLayer","cpe":[],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-95","name":"Improper Neutralization of Directives in Dynamically Evaluated Code"}],"description":"An arbitrary code execution vulnerability exists in versions 0.2.9 up to 0.5.10 of the Guardrails AI Guardrails framework because of the way it validates XML files. If a victim user loads a maliciously crafted XML file containing Python code, the code will be passed to an eval function, causing it to execute on the user's machine.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Guardrails has an arbitrary code execution vulnerability","id":"CVE-2024-45858","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"Use of Hard-coded Credentials in Kastle Systems Access Control System","id":"CVE-2024-45861"},"packages":[{"ecosystem":"PyPI","fixed":["0.5.10"],"introduced":["0.2.9"],"last_affected":[],"package":"guardrails-ai","purl":null,"source":"GHSA-w392-75q8-vr67"},{"ecosystem":"PyPI","fixed":["0.5.10"],"introduced":["0.2.9"],"last_affected":[],"package":"guardrails-ai","purl":"pkg:pypi/guardrails-ai","source":"GHSA-w392-75q8-vr67"},{"ecosystem":"PyPI","fixed":["0.5.10"],"introduced":["0.2.9"],"last_affected":[],"package":"guardrails-ai","purl":"pkg:pypi/guardrails-ai","source":"PYSEC-2026-1432"}],"prev":{"headline":"Cleanlab Deserialization of Untrusted Data vulnerability","id":"CVE-2024-45857"},"products":["guardrails"],"published":"2024-09-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-18","vendors":["Guardrails AI"]},"summary":"Attackers can execute arbitrary code on user machines by tricking them into loading malicious XML files processed by the Guardrails AI framework.","url":"https://insights.sbomify.com/CVE-2024-45858/"}