# CVE-2024-45858: Guardrails has an arbitrary code execution vulnerability

> Attackers can execute arbitrary code on user machines by tricking them into loading malicious XML files processed by the Guardrails AI framework.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Sep 2024
- **Updated:** 18 Sep 2024
- **Also known as:** GHSA-w392-75q8-vr67, PYSEC-2026-1432

## What is CVE-2024-45858?

CVE-2024-45858 is a high-severity code injection vulnerability in guardrails, published on 18 Sep 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

An arbitrary code execution vulnerability exists in versions 0.2.9 up to 0.5.10 of the Guardrails AI Guardrails framework because of the way it validates XML files. If a victim user loads a maliciously crafted XML file containing Python code, the code will be passed to an eval function, causing it to execute on the user's machine.

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2024-45858?

3 open source packages ship an affected version, including guardrails-ai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `guardrails-ai` | PyPI | From 0.2.9 | 0.5.10 |
| `guardrails-ai` | PyPI | From 0.2.9 | 0.5.10 |
| `guardrails-ai` | PyPI | From 0.2.9 | 0.5.10 |

## How do I fix CVE-2024-45858?

Upgrade guardrails-ai to 0.5.10 or later.

## Is CVE-2024-45858 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45858 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45858 and fix it if it is affected.

What it is: CVE-2024-45858 is a high-severity code injection vulnerability in guardrails, published on 18 Sep 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45858 exists.

Affected packages and fixed versions:
- guardrails-ai (PyPI): affected from 0.2.9; fixed in 0.5.10
- guardrails-ai (PyPI): affected from 0.2.9; fixed in 0.5.10
- guardrails-ai (PyPI): affected from 0.2.9; fixed in 0.5.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45858/ (Markdown: https://insights.sbomify.com/CVE-2024-45858/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45858
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45858
- OSV: https://osv.dev/vulnerability/CVE-2024-45858

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45858/
Summaries are generated and may contain mistakes; the official description above is the record.
