CVE-2024-4596 Kimai Session information disclosure

Low 3.7 Published Updated

Remote attackers can disclose session information via manipulated PHPSESSIONID arguments in Kimai, requiring high complexity and permissions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-4596?

CVE-2024-4596 is a low-severity vulnerability in Kimai, published on 7 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability was found in Kimai up to 2.15.0 and classified as problematic. Affected by this issue is some unknown functionality of the component Session Handler. The manipulation of the argument PHPSESSIONID leads to information disclosure. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. Upgrading to version 2.16.0 is able to address this issue. It is recommended to upgrade the affected component. VDB-263318 is the identifier assigned to this vulnerability.

Weakness: CWE-200

Which versions are affected by CVE-2024-4596?

2 open source packages ship an affected version, including kimai/kimai. It affects 1 product.

PackageAffectedFixed in
kimai/kimai PackagistAll versions2.16.0
kimai/kimai PackagistAll versions2.16.0

Products include Kimai Kimai.

How do I fix CVE-2024-4596?

Upgrade kimai/kimai to 2.16.0 or later.

Is CVE-2024-4596 being exploited?

There is no known exploitation of CVE-2024-4596 in the wild and no public exploit code.

Sources

Also known as GHSA-6f3v-2r2j-2rpr.

Is CVE-2024-4596 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free