{"answers":{"affected":"2 open source packages ship an affected version, including kimai/kimai. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-4596 in the wild and no public exploit code.","fix":"Upgrade kimai/kimai to 2.16.0 or later.","what":"CVE-2024-4596 is a low-severity vulnerability in Kimai, published on 7 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-4596 and fix it if it is affected.\n\nWhat it is: CVE-2024-4596 is a low-severity vulnerability in Kimai, published on 7 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-4596 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- kimai/kimai (Packagist): affected all versions; fixed in 2.16.0\n- kimai/kimai (Packagist): affected all versions; fixed in 2.16.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-4596/ (Markdown: https://insights.sbomify.com/CVE-2024-4596/index.md)","id":"CVE-2024-4596","markdown":"https://insights.sbomify.com/CVE-2024-4596/index.md","name":"CVE-2024-4596","record":{"aliases":["GHSA-6f3v-2r2j-2rpr"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Kimai time tracking","requires_auth":"none","summary":"Remote attackers can disclose session information via manipulated PHPSESSIONID arguments in Kimai, requiring high complexity and permissions.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"kimai","vendor":"kimai"}],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"A vulnerability was found in Kimai up to 2.15.0 and classified as problematic. Affected by this issue is some unknown functionality of the component Session Handler. The manipulation of the argument PHPSESSIONID leads to information disclosure. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. Upgrading to version 2.16.0 is able to address this issue. It is recommended to upgrade the affected component. VDB-263318 is the identifier assigned to this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Kimai Session information disclosure","id":"CVE-2024-4596","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":2,"n_references":4,"next":{"headline":"Cross-Site Request Forgery (CSRF) in GitLab","id":"CVE-2024-4597"},"packages":[{"ecosystem":"Packagist","fixed":["2.16.0"],"introduced":["0"],"last_affected":[],"package":"kimai/kimai","purl":null,"source":"GHSA-6f3v-2r2j-2rpr"},{"ecosystem":"Packagist","fixed":["2.16.0"],"introduced":["0"],"last_affected":[],"package":"kimai/kimai","purl":"pkg:composer/kimai/kimai","source":"GHSA-6f3v-2r2j-2rpr"}],"prev":{"headline":"SEMCMS function.php locate sql injection","id":"CVE-2024-4595"},"products":["Kimai"],"published":"2024-05-07","related":[{"cvss_score":9.6,"headline":"Cross-site Scripting in kimai/kimai","id":"CVE-2020-19825","kev_date_added":null,"published":"2023-02-15"},{"cvss_score":8.5,"headline":"Kimai 1.30.10 SameSite Cookie Vulnerability Session Hijacking","id":"CVE-2023-53957","kev_date_added":null,"published":"2025-12-19"},{"cvss_score":7.8,"headline":"Improper Neutralization of Formula Elements in a CSV File in Kimai 2","id":"CVE-2021-43515","kev_date_added":null,"published":"2022-04-08"},{"cvss_score":7.2,"headline":"Kimai (Authenticated) SSTI to RCE by Uploading a Malicious Twig File","id":"CVE-2023-46245","kev_date_added":null,"published":"2023-10-31"},{"cvss_score":6.8,"headline":"Kimai Vulnerable to Authenticated Server-Side Template Injection (SSTI)","id":"CVE-2026-23626","kev_date_added":null,"published":"2026-01-18"},{"cvss_score":6.8,"headline":"API returns timesheet entries a user should not be authorized to view","id":"CVE-2024-29200","kev_date_added":null,"published":"2024-03-28"},{"cvss_score":6.5,"headline":"Kimai: API invoice endpoint missing customer-level access control (IDOR)","id":"CVE-2026-28685","kev_date_added":null,"published":"2026-03-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["n/a"]},"summary":"Remote attackers can disclose session information via manipulated PHPSESSIONID arguments in Kimai, requiring high complexity and permissions.","url":"https://insights.sbomify.com/CVE-2024-4596/"}