# CVE-2024-4596: Kimai Session information disclosure

> Remote attackers can disclose session information via manipulated PHPSESSIONID arguments in Kimai, requiring high complexity and permissions.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-6f3v-2r2j-2rpr

## What is CVE-2024-4596?

CVE-2024-4596 is a low-severity vulnerability in Kimai, published on 7 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in Kimai up to 2.15.0 and classified as problematic. Affected by this issue is some unknown functionality of the component Session Handler. The manipulation of the argument PHPSESSIONID leads to information disclosure. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. Upgrading to version 2.16.0 is able to address this issue. It is recommended to upgrade the affected component. VDB-263318 is the identifier assigned to this vulnerability.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-4596?

2 open source packages ship an affected version, including kimai/kimai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kimai/kimai` | Packagist | All versions | 2.16.0 |
| `kimai/kimai` | Packagist | All versions | 2.16.0 |

Products: Kimai Kimai.

## How do I fix CVE-2024-4596?

Upgrade kimai/kimai to 2.16.0 or later.

## Is CVE-2024-4596 being exploited?

There is no known exploitation of CVE-2024-4596 in the wild and no public exploit code.

## Other vulnerabilities in Kimai

- [CVE-2020-19825](https://insights.sbomify.com/CVE-2020-19825/): Cross-site Scripting in kimai/kimai (critical 9.6)
- [CVE-2023-53957](https://insights.sbomify.com/CVE-2023-53957/): Kimai 1.30.10 SameSite Cookie Vulnerability Session Hijacking (high 8.5)
- [CVE-2021-43515](https://insights.sbomify.com/CVE-2021-43515/): Improper Neutralization of Formula Elements in a CSV File in Kimai 2 (high 7.8)
- [CVE-2023-46245](https://insights.sbomify.com/CVE-2023-46245/): Kimai (Authenticated) SSTI to RCE by Uploading a Malicious Twig File (high 7.2)
- [CVE-2026-23626](https://insights.sbomify.com/CVE-2026-23626/): Kimai Vulnerable to Authenticated Server-Side Template Injection (SSTI) (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-4596 and fix it if it is affected.

What it is: CVE-2024-4596 is a low-severity vulnerability in Kimai, published on 7 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-4596 in the wild and no public exploit code.

Affected packages and fixed versions:
- kimai/kimai (Packagist): affected all versions; fixed in 2.16.0
- kimai/kimai (Packagist): affected all versions; fixed in 2.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-4596/ (Markdown: https://insights.sbomify.com/CVE-2024-4596/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-4596
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-4596
- OSV: https://osv.dev/vulnerability/CVE-2024-4596

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-4596/
Summaries are generated and may contain mistakes; the official description above is the record.
