CVE-2024-4597 Cross-Site Request Forgery (CSRF) in GitLab

Medium 5.7 Published Updated

An attacker can force a user with an active SAML session to approve a merge request via Cross-Site Request Forgery.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-4597?

CVE-2024-4597 is a medium-severity vulnerability in Gitlab Gitlab, published on 9 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab EE affecting all versions from 16.7 before 16.9.7, all versions starting from 16.10 before 16.10.5, all versions starting from 16.11 before 16.11.2. An attacker could force a user with an active SAML session to approve an MR via CSRF.

Weakness: CWE-352

Which versions are affected by CVE-2024-4597?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.7.016.9.7, 16.10.5, 16.11.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-4597?

Upgrade gitlab to a fixed version for your release line: 16.9.7, 16.10.5 or 16.11.2.

Is CVE-2024-4597 being exploited?

There is no known exploitation of CVE-2024-4597 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-4597, GHSA-7xp2-7fx4-46xp.

Is CVE-2024-4597 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free