{"answers":{"affected":"2 open source packages ship an affected version, including modsecurity and modsecurity2. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-46292 exists.","fix":"Upgrade modsecurity to 3.0.13 or later.","what":"CVE-2024-46292 is a high-severity memory corruption vulnerability in n/a, published on 9 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-46292 and fix it if it is affected.\n\nWhat it is: CVE-2024-46292 is a high-severity memory corruption vulnerability in n/a, published on 9 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-46292 exists.\n\nAffected packages and fixed versions:\n- modsecurity (Bitnami): affected from 3.0.12; fixed in 3.0.13\n- modsecurity2 (Bitnami): affected from 3.0.12 up to 3.0.12; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-46292/ (Markdown: https://insights.sbomify.com/CVE-2024-46292/index.md)","id":"CVE-2024-46292","markdown":"https://insights.sbomify.com/CVE-2024-46292/index.md","name":"CVE-2024-46292","record":{"aliases":["BIT-modsecurity-2024-46292","BIT-modsecurity2-2024-46292","GHSA-gmcv-mjv9-gjcv","UBUNTU-CVE-2024-46292"],"analysis":{"component_type":"server_software","fix_type":"no_fix_stated","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Web application firewall","requires_auth":"none","summary":"A disputed buffer overflow in ModSecurity could allow attackers to cause a denial of service via crafted input, though reproduction is unconfirmed.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"modsecurity","vendor":"trustwave"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-120","name":"Buffer Copy without Checking Size of Input"}],"description":"A buffer overflow in modsecurity v3.0.12 allows attackers to cause a Denial of Service (DoS) via a crafted input inserted into the name parameter. NOTE: this is disputed by the Supplier because it cannot be reproduced. Also, the product's documentation indicates that it is not guaranteed to be usable with very large values of SecRequestBodyNoFilesLimit (which are required by the claimed issue).","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2024-46292","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"memory_corruption","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Missing authorization in n/a","id":"CVE-2024-46293"},"packages":[{"ecosystem":"Bitnami","fixed":["3.0.13"],"introduced":["3.0.12"],"last_affected":[],"package":"modsecurity","purl":"pkg:bitnami/modsecurity","source":"BIT-modsecurity-2024-46292"},{"ecosystem":"Bitnami","fixed":[],"introduced":["3.0.12"],"last_affected":["3.0.12"],"package":"modsecurity2","purl":"pkg:bitnami/modsecurity2","source":"BIT-modsecurity2-2024-46292"}],"prev":{"headline":"Hardcoded credentials in n/a","id":"CVE-2024-46280"},"products":["n/a"],"published":"2024-10-09","related":[{"cvss_score":7.9,"headline":"Libmodsecurity3 has possible bypass of encoded HTML entities","id":"CVE-2025-27110","kev_date_added":null,"published":"2025-02-25"},{"cvss_score":7.5,"headline":"ModSecurity Has Possible DoS Vulnerability","id":"CVE-2025-47947","kev_date_added":null,"published":"2025-05-21"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-20","vendors":["n/a"]},"summary":"A disputed buffer overflow in ModSecurity could allow attackers to cause a denial of service via crafted input, though reproduction is unconfirmed.","url":"https://insights.sbomify.com/CVE-2024-46292/"}