# CVE-2024-46292: Memory corruption in n/a

> A disputed buffer overflow in ModSecurity could allow attackers to cause a denial of service via crafted input, though reproduction is unconfirmed.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Oct 2024
- **Updated:** 20 Oct 2024
- **Also known as:** BIT-modsecurity-2024-46292, BIT-modsecurity2-2024-46292, GHSA-gmcv-mjv9-gjcv, UBUNTU-CVE-2024-46292

## What is CVE-2024-46292?

CVE-2024-46292 is a high-severity memory corruption vulnerability in n/a, published on 9 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A buffer overflow in modsecurity v3.0.12 allows attackers to cause a Denial of Service (DoS) via a crafted input inserted into the name parameter. NOTE: this is disputed by the Supplier because it cannot be reproduced. Also, the product's documentation indicates that it is not guaranteed to be usable with very large values of SecRequestBodyNoFilesLimit (which are required by the claimed issue).

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2024-46292?

2 open source packages ship an affected version, including modsecurity and modsecurity2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `modsecurity` | Bitnami | From 3.0.12 | 3.0.13 |
| `modsecurity2` | Bitnami | From 3.0.12 to 3.0.12 | None |

Products: Trustwave Modsecurity.

## How do I fix CVE-2024-46292?

Upgrade modsecurity to 3.0.13 or later.

## Is CVE-2024-46292 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-46292 exists.

## Other vulnerabilities in n/a

- [CVE-2025-27110](https://insights.sbomify.com/CVE-2025-27110/): Libmodsecurity3 has possible bypass of encoded HTML entities (high 7.9)
- [CVE-2025-47947](https://insights.sbomify.com/CVE-2025-47947/): ModSecurity Has Possible DoS Vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-46292 and fix it if it is affected.

What it is: CVE-2024-46292 is a high-severity memory corruption vulnerability in n/a, published on 9 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-46292 exists.

Affected packages and fixed versions:
- modsecurity (Bitnami): affected from 3.0.12; fixed in 3.0.13
- modsecurity2 (Bitnami): affected from 3.0.12 up to 3.0.12; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-46292/ (Markdown: https://insights.sbomify.com/CVE-2024-46292/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-46292
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-46292
- OSV: https://osv.dev/vulnerability/CVE-2024-46292

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-46292/
Summaries are generated and may contain mistakes; the official description above is the record.
