# CVE-2024-46488: Heap-based Buffer Overflow in sqlite-vec

> Attackers can cause a denial of service via a crafted file due to a heap buffer overflow in the sqlite-vec library.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2024
- **Updated:** 25 Sep 2024
- **Also known as:** GHSA-vrcx-gx3g-j3h8, PYSEC-2026-1938

## What is CVE-2024-46488?

CVE-2024-46488 is a critical memory corruption vulnerability in n/a, published on 25 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

sqlite-vec v0.1.1 was discovered to contain a heap buffer overflow via the npy_token_next function. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted file.

Weakness: CWE-787 (Out-of-bounds Write), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2024-46488?

9 open source packages ship an affected version, including sqlite-vec. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sqlite-vec` | PyPI | All versions | 0.1.3 |
| `sqlite-vec` | PyPI | All versions | 0.1.3 |
| `sqlite-vec` | PyPI | All versions | 0.1.3 |
| `sqlite-vec` | RubyGems | All versions | 0.1.3 |
| `sqlite-vec` | RubyGems | All versions | 0.1.3 |
| `sqlite-vec` | crates.io | All versions | 0.1.3 |
| `sqlite-vec` | crates.io | All versions | 0.1.3 |
| `sqlite-vec` | npm | All versions | 0.1.3 |
| `sqlite-vec` | npm | All versions | 0.1.3 |

Products: Asg017 Sqlite-Vec.

## How do I fix CVE-2024-46488?

Upgrade sqlite-vec to 0.1.3 or later.

## Is CVE-2024-46488 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-46488 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-46488 and fix it if it is affected.

What it is: CVE-2024-46488 is a critical memory corruption vulnerability in n/a, published on 25 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-46488 exists.

Affected packages and fixed versions:
- sqlite-vec (PyPI): affected all versions; fixed in 0.1.3
- sqlite-vec (PyPI): affected all versions; fixed in 0.1.3
- sqlite-vec (PyPI): affected all versions; fixed in 0.1.3
- sqlite-vec (RubyGems): affected all versions; fixed in 0.1.3
- sqlite-vec (RubyGems): affected all versions; fixed in 0.1.3
- sqlite-vec (crates.io): affected all versions; fixed in 0.1.3
- sqlite-vec (crates.io): affected all versions; fixed in 0.1.3
- sqlite-vec (npm): affected all versions; fixed in 0.1.3
- sqlite-vec (npm): affected all versions; fixed in 0.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-46488/ (Markdown: https://insights.sbomify.com/CVE-2024-46488/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-46488
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-46488
- OSV: https://osv.dev/vulnerability/CVE-2024-46488

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-46488/
Summaries are generated and may contain mistakes; the official description above is the record.
