CVE-2024-46528 KubeSphere IDOR vulnerability
Low-privileged attackers can access sensitive resources without proper authorization checks in KubeSphere.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-46528?
CVE-2024-46528 is a medium-severity missing authorization vulnerability in n/a, published on 14 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An Insecure Direct Object Reference (IDOR) vulnerability in KubeSphere 4.x before 4.1.3 and 3.x through 3.4.1 and KubeSphere Enterprise 4.x before 4.1.3 and 3.x through 3.5.0 allows low-privileged authenticated attackers to access sensitive resources without proper authorization checks.
Weakness: CWE-639
Which versions are affected by CVE-2024-46528?
5 open source packages ship an affected version, including github.com/kubesphere/kubesphere.
| Package | Affected | Fixed in |
|---|---|---|
github.com/kubesphere/kubesphere Go | All versions | None |
github.com/kubesphere/kubesphere Go | From 3.0.0 | 3.4.1 |
github.com/kubesphere/kubesphere Go | From 3.0.0 | 3.4.1 |
github.com/kubesphere/kubesphere Go | From 4.0.0 | 4.1.3 |
github.com/kubesphere/kubesphere Go | From 4.0.0 | 4.1.3 |
How do I fix CVE-2024-46528?
Upgrade github.com/kubesphere/kubesphere to a fixed version for your release line: 3.4.1 or 4.1.3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-46528 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-46528 exists.
Public exploit code: 1 Exploit-DB entry.
Sources
Also known as GHSA-p26r-gfgc-c47h, GO-2024-3248.