{"answers":{"affected":"5 open source packages ship an affected version, including github.com/kubesphere/kubesphere.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-46528 exists.","fix":"Upgrade github.com/kubesphere/kubesphere to a fixed version for your release line: 3.4.1 or 4.1.3.","what":"CVE-2024-46528 is a medium-severity missing authorization vulnerability in n/a, published on 14 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-46528 and fix it if it is affected.\n\nWhat it is: CVE-2024-46528 is a medium-severity missing authorization vulnerability in n/a, published on 14 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-46528 exists.\n\nAffected packages and fixed versions:\n- github.com/kubesphere/kubesphere (Go): affected all versions; no fix listed\n- github.com/kubesphere/kubesphere (Go): affected from 3.0.0; fixed in 3.4.1\n- github.com/kubesphere/kubesphere (Go): affected from 3.0.0; fixed in 3.4.1\n- github.com/kubesphere/kubesphere (Go): affected from 4.0.0; fixed in 4.1.3\n- github.com/kubesphere/kubesphere (Go): affected from 4.0.0; fixed in 4.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-46528/ (Markdown: https://insights.sbomify.com/CVE-2024-46528/index.md)","id":"CVE-2024-46528","markdown":"https://insights.sbomify.com/CVE-2024-46528/index.md","name":"CVE-2024-46528","record":{"aliases":["GHSA-p26r-gfgc-c47h","GO-2024-3248"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Kubernetes management platform","requires_auth":"low_privilege","summary":"Low-privileged attackers can access sensitive resources without proper authorization checks in KubeSphere.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":4.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"}],"description":"An Insecure Direct Object Reference (IDOR) vulnerability in KubeSphere 4.x before 4.1.3 and 3.x through 3.4.1 and KubeSphere Enterprise 4.x before 4.1.3 and 3.x through 3.5.0 allows low-privileged authenticated attackers to access sensitive resources without proper authorization checks.","ecosystems":["Go"],"exploits":{"exploitdb":1,"first_seen":"2025-03-27","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-03-27","kind":"exploitdb","ref":"52097","stars":null,"title":"KubeSphere 3.4.0 - Insecure Direct Object Reference (IDOR)"}],"tier":"weaponised"},"has_fix":true,"headline":"KubeSphere IDOR vulnerability","id":"CVE-2024-46528","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":5,"n_references":3,"next":{"headline":"SQL injection in n/a","id":"CVE-2024-46531"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/kubesphere/kubesphere","purl":"pkg:golang/github.com/kubesphere/kubesphere","source":"GO-2024-3248"},{"ecosystem":"Go","fixed":["3.4.1"],"introduced":["3.0.0"],"last_affected":[],"package":"github.com/kubesphere/kubesphere","purl":null,"source":"GHSA-p26r-gfgc-c47h"},{"ecosystem":"Go","fixed":["3.4.1"],"introduced":["3.0.0"],"last_affected":[],"package":"github.com/kubesphere/kubesphere","purl":"pkg:golang/github.com/kubesphere/kubesphere","source":"GHSA-p26r-gfgc-c47h"},{"ecosystem":"Go","fixed":["4.1.3"],"introduced":["4.0.0"],"last_affected":[],"package":"github.com/kubesphere/kubesphere","purl":null,"source":"GHSA-p26r-gfgc-c47h"},{"ecosystem":"Go","fixed":["4.1.3"],"introduced":["4.0.0"],"last_affected":[],"package":"github.com/kubesphere/kubesphere","purl":"pkg:golang/github.com/kubesphere/kubesphere","source":"GHSA-p26r-gfgc-c47h"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2024-46511"},"products":["n/a"],"published":"2024-10-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-28","vendors":["n/a"]},"summary":"Low-privileged attackers can access sensitive resources without proper authorization checks in KubeSphere.","url":"https://insights.sbomify.com/CVE-2024-46528/"}