CVE-2024-46544 Apache Tomcat Connectors: mod_jk: local users can view and modify configuration

Medium 5.9 Published Updated

Local users can view and modify mod_jk shared memory configuration, leading to information disclosure or denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2024-46544?

CVE-2024-46544 is a medium-severity vulnerability in Debian Debian Linux, published on 23 Sep 2024. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Incorrect Default Permissions vulnerability in Apache Tomcat Connectors allows local users to view and modify shared memory containing mod_jk configuration which may lead to information disclosure and/or denial of service.

This issue affects Apache Tomcat Connectors: from 1.2.9-beta through 1.2.49. Only mod_jk on Unix like systems is affected. Neither the ISAPI redirector nor mod_jk on Windows is affected.

Users are recommended to upgrade to version 1.2.50, which fixes the issue.

Weakness: CWE-276

Which versions are affected by CVE-2024-46544?

It affects 2 products.

Linux distribution packages (12)
mod_jk AlmaLinux:9All versions1.2.50-1.el9_4.1
mod_jk Red Hat:enterprise_linux:9::appstreamAll versions0:1.2.50-1.el9_4.1
mod_jk-debuginfo Red Hat:enterprise_linux:9::appstreamAll versions0:1.2.50-1.el9_4.1
mod_jk-debugsource Red Hat:enterprise_linux:9::appstreamAll versions0:1.2.50-1.el9_4.1
mod_jk Red Hat:rhel_e4s:9.0::appstreamAll versions0:1.2.50-1.el9_0.1
mod_jk-debuginfo Red Hat:rhel_e4s:9.0::appstreamAll versions0:1.2.50-1.el9_0.1
mod_jk-debugsource Red Hat:rhel_e4s:9.0::appstreamAll versions0:1.2.50-1.el9_0.1
mod_jk Red Hat:rhel_eus:9.2::appstreamAll versions0:1.2.50-1.el9_2.1
mod_jk-debuginfo Red Hat:rhel_eus:9.2::appstreamAll versions0:1.2.50-1.el9_2.1
mod_jk-debugsource Red Hat:rhel_eus:9.2::appstreamAll versions0:1.2.50-1.el9_2.1
mod_jk Rocky Linux:9All versions0:1.2.50-1.el9_4.1
apache2-mod_jk SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5All versions1.2.50-7.12.1

Products include Apache Tomcat Connectors, Debian Debian Linux.

How do I fix CVE-2024-46544?

Upgrade to a fixed version.

Is CVE-2024-46544 being exploited?

There is no known exploitation of CVE-2024-46544 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as ALSA-2024:7457, CLSA-2026-1779204030, DEBIAN-CVE-2024-46544, DLA-3919-1, GHSA-2582-53pq-96cq, MGASA-2024-0315 and 7 more.

Is CVE-2024-46544 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free